17 posts / 0 new
Last post
Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
About DA14582

Hi,Dialog!

Now I want to programming for the debugger with DA14582, I have the following questions:

1. Which version of SmartSnippets supports DA14582?
2. Which port is selected as UART port ( Tx-Rx pair) connecting FTDI the the board for the SmartSnippets?
3. If use the JTAG to debug the program, which GPIO to be used?

Looking foward to your reply.

Device: 
MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Bean

Hi Bean

1) You can use the all the versions of SmartSnippets.

2) You can use the pins P1_3 and P0_4 (Rx/Tx)

3) The pins for the JTAG are the SWDIO and SWCLK pins.

Thanks MT_dialog.

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi,MT_dialog!

Hi,MT_dialog!

Now I use the SmartSnippets is v3.6, when open it, I don't see the option for DA14582, but I can see that DA14580-00 ,DA14580-01 and DA14581.

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi,Dialog!

Hi,Dialog!

Could you help me?

Thank you !

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Bean,

Hi Bean,

You can use the DA14580-01 option, the 14582 its a DA14580 + SC14439 chip.

Thanks MT_dialog

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi,MT_dialog!

Hi,MT_dialog!

My above problem has been solved ,thank you very much!
Now I have a new problem about the connection. The SDK I used is DA14580_DA14582_REMOTE_AUDIO_v_3.140.2.39 , and the andoid APP is BleRemote_v_3.140.2.39.apk.
When the android app discover the device, but can not connected with the device.
I need the help! Can you help me?

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Bean,

Hi Bean,

Can your remote connect and function with your android (no application) ? What is your android version?

Thanks MT_dialog

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi,MT_dialog!

Hi,MT_dialog!

The version of my android phone device is 5.1.1 , and the apk is BleRemote_v_3.140.2.39.apk.
After I compile the DA14580_DA14582_REMOTE_AUDIO_v_3.140.2.39 , and download the *.hex to my development Board , it is connected with my android phone device (the bluetooth in the setting of my phone), but it is not connected with BleRemote_v_3.140.2.39.apk.
According to my tracking,the log is :
--> NO_EVENT
(N) IDLE
KBD active (HW scan)

**> IDLE
--> KEY_PRESS
(N) CONNECTION_IN_PROGRESS
KBD active (HW scan)
gap_le_create_conn_req_cmp_evt_handler() (39, 0, 700, 5)
Peer addr 2a:b6:d0:ab:e3:88

**> CONNECTION_IN_PROGRESS
--> CONN_REQ
(N) CONNECTED_PAIRING
(+) Connection FSM ENC timer
ENC timer exp

**> CONNECTED_PAIRING
--> DISCONN
(-) ENC timer
(N) CONNECTION_IN_PROGRESS
KBD HID rep OFF
gap_le_create_conn_req_cmp_evt_handler() (39, 0, 2000, 5)
Peer addr 2a:b6:d0:ab:e3:88

**> CONNECTION_IN_PROGRESS
--> CONN_REQ
(N) CONNECTED_PAIRING
(+) Connection FSM ENC timer
ENC timer exp

**> CONNECTED_PAIRING
--> DISCONN
(-) ENC timer
(N) CONNECTION_IN_PROGRESS
KBD HID rep OFF

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Bean,

Hi Bean,

Sorry but there is an issue with this apk and android devices above 5.1. According to our android specialist there is a permission check added in the bluetooth library in version 5.1, for many common ble operations. When the operation refers to an HID characteristic, the system checks for the BLUETOOTH_PRIVILEGED permission. The problem is that this permission in not available for user apps, so, even if the manifest file is set, it is ignored. It is only available for privileged system apps.

Thanks MT_dialog

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi,MT_dialog!

Hi,MT_dialog!

Before, I can do that compile the DA14580_DA14582_REMOTE_AUDIO_v_3.140.2.39 , and download the *.hex to my development Board. The boad can be connected with BleRemote_v_3.140.2.39.apk,and I press the up and down button on the boad, the corresponding buttons on the BleRemote_v_3.140.2.39.apk is pressed!

But now, it is not! I don't know that the connection is abnormal!

How should I do ?

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Bean,

Hi Bean,

Can you remember what intervened between the working and the not working states of the application? Maybe there was a phone update? Can you try it to a device with an android version less than 5.1 ?

Thanks MT_dialog

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi,MT_dialog!

Hi,MT_dialog!

Thank you for the problems that you proposed! Before updating the android system less than 5.1 for my android device, I'd like to confirm the following questions from you:

1.Even if the manifest file is set, the BLUETOOTH_PRIVILEGED permission is not available for the user app?
<?xml version="1.0" encoding="utf-8"?>

2. In addittion to update the sistem less than 5.1, what the other method or what should we do?

Thank you!

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi,MT_dialog!

Hi,MT_dialog!
I'm sorry, just lack of the following main contents!Now I submitted to complete the following content.

Thank you for the problems that you proposed! Before updating the android system less than 5.1 for my android device, I'd like to confirm the following questions from you:

1.Even if the manifest file is set, the BLUETOOTH_PRIVILEGED permission is not available for the user app?
<?xml version="1.0" encoding="utf-8"?>

2. In addittion to update the sistem less than 5.1, what the other method or what should we do?

Thank you!

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi,MT_dialog!

Hi,MT_dialog!

I'm very sorry for that Repeat the question . I originally want to commit the contents of the AndroidManifest.xml file. But it is not!

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Bean,

Hi Bean,

1. Thats right.

2. The procedure for running the application without downgrading your system is a bit complicated and it requires a rooted device in order to make the 
    application a system application, and also it requires a modified .apk, if you want some more info in order to perform this kind of configuration please let me know.

Thanks MT_dialog

Bean
Offline
Last seen: 5 years 1 month ago
Joined: 2014-07-24 08:51
Hi, MT_dialog!

Hi, MT_dialog!

Thank you!
After I root the device, I have two questions
1.How can I modify the apk?
2.What should I do for the apk?

Thank you !

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Bean,

Hi Bean,

Mail sent.

Thanks MT_dialog

Topic locked