Another Problem with UM-B-014 demo

6 posts / 0 new
Last post
DrNick1
Offline
Last seen: 5 years 11 months ago
Joined: 2014-07-01 11:55
Another Problem with UM-B-014 demo

Having followed the instructions for the demo in Document DA14580 Development Kit User Manual, I get the same issues other people have had when I get to instruction 4.4.1.6 to open the settings on the J-Link.
Clicking this button results in Keil crashing.
Using J-Link commander I can see the J-Link ok, but it can't see any cores. I have tried two J-links/cables and both motherboards.
I have also tried using Keil 4 and Keil 5, with the same result. A crash.

All software is up to date.

The other solutions posted here do not work. Note my demo kit is an early one, with Motherboard rev B1. Could it be a power issue? Everything seems powered up.
Note if I select another target device such as one of the STM M0 cores then I can click the settings button successfully and settings are reported, but I don't have an STM core attached so that doesn't really help!

Any advice?

JE_Dialog
Offline
Last seen: 11 months 3 weeks ago
Staff
Joined: 2013-12-05 14:02
Hi Dr Nick,

Hi Dr Nick,

it does seem that you have a very early version of the motherboard .. we are currently shipping rev C.2 boards. There was a fix to update rev C.1 boards that changed a voltage setting and a UART I/O setting for a SDK update.

http://support.dialog-semiconductor.com/resource/expert-da14580-devkit-motherboard-schematic

Also, which version of the device (daughterboard) are you using ? you should be workign with DA14580-01 , and not older ES4 or ES5 versions which were pre-release. If you have older versions, I will arrange a FOC swap out for you.

We are also experiencing some problems with the latest version of Keil and are in contact with them to find the root cause. I found on my own machine the database did not update and it also crashes... we aim to get to the root of this ASAP.

Best regards,
JE_Dialog

DrNick1
Offline
Last seen: 5 years 11 months ago
Joined: 2014-07-01 11:55
Many thanks for the reply.

Many thanks for the reply.

The daughterboard I am using doesn't obviously have any of the numbers you quote, but has the following on the screen print
DA14580_CB_PXI_WLCSP
078-04-A

Do you have any other details for the changes you mention? The corrections you list are for the C issue and I still have the B issue. Is there an older SDK I can go back to. I'm quite prepared to hack the board about if they are simple changes but I'd need to know the places to start. If its too complicated I'm probably better off getting a new kit.

JE_Dialog
Offline
Last seen: 11 months 3 weeks ago
Staff
Joined: 2013-12-05 14:02
Hi There, it looks like you

Hi There, it looks like you have an engineering sample : so i will organise a FOC swap out for you . It woudl be muhc better to start from a clear baseline.  Let me send you a message and i will set those wheels in motion.

BR JE_DIalog.

afrid
Offline
Last seen: 2 years 7 months ago
Joined: 2019-03-12 14:31
Hi,

Hi,

can you please share me link for the instructions for the demo in Document DA14580 Development Kit User Manual

PM_Dialog
Offline
Last seen: 6 months 3 weeks ago
Staff
Joined: 2018-02-08 11:03
Hi afrid,

Hi afrid,

You asked about the UM-B-014 document and I have already replied you in the form thread below:

https://support.dialog-semiconductor.com/forums/post/dialog-smartbond-bluetooth-low-energy-%E2%80%93-software/adding-new-service-due-running-low-heap

I would kindly suggest you to not post in old forum threads. Please create a new forum thread next time!

Thanks, PM_Dialog