DA14531 SmartBond TINY Module

Download a configuration file

Thu, 2020-09-24 17:48 -- pchignon

Hi,

Currently, i use a STM32F4 to pilot the DA14531, the DA14531 is working on advertising to send informations to a smartphone or another embedded board.

Everithing is ok,  but i need to download from the smartphone a small configuration file (1k) to the DA14531 and after between the DA14531 to my STM32F4 via serial port.

DA14531 firmware update without using motherboard

Tue, 2020-09-22 15:53 -- cole

I would like to program the Codeless AT firmware into a DA14531 Tiny module. I have the hex file, and I have SmartSnippetsStudio2.0.14 installed on my Linux machine. However, SmartSnippets can't seem to connect to the module. I see serial port activity on the scope, so I think the serial port is correct. I am using 1 wire to J14 (P0_5). My hardware setup is:

 

Linux host -> FTDI interface -> 2-wire to 1-wire circuit -> DA14531 Tiny module

 

Device is not visiable in BLEScanner after I disconnect and connect the power supply to DA14531 MOD

Wed, 2020-09-16 12:40 -- ravikiran4

I am using DA14531 MOD with SDK 6.0.14.

I have modified the example Measuring Temperature provided on your web page https://www.dialog-semiconductor.com/sites/default/files/da14531-da14585... based on my requirement. 

When I first download the firmware .hex file into the board using SmartSnippets ToolBox v5.0.14 then the device is visible in my BLE scanner application I am able to get data by requesting it.

Can't connect to DA14531 after putting it in hibernation

Wed, 2020-09-16 09:57 -- innovativepower

Hello,

I tried to get the DA14531 module in hibernation with the da14531_configuring_da14531_hibernation_mode example code. This example was not working properly, because I measured a current consumption of 10uA, both on the power profiler and a multimeter. After trying to flash a different example, I couldn't get the module to connect on the pro devkit. I've had similar problems before, but when I flashed the module via UART it worked fine again. Now, the module isn't responding to SWD, 1-wire UART, 2-wire UART, and SPI.

Sleepmode on Peripheral Example

Tue, 2020-09-08 22:46 -- magergar

Hi,

I've been wondering if it's posible to activate the sleep mode on any of the peripheral examples (without bluetooth)

what I'm trying to acomplish is to read an ADC value(sensor) and if it's above certain value turn on an opto but I only have 10mA to do this

using the SmartSnippets Toolbox I can read what I'm cosuming and the module DA14531 alone without any active peripherals works with 10mA

so my idea was to put the module to sleep and somehow set up a timer to wakeup and measure the adc and once the condition is met activate the opto

Pages

Subscribe to RSS - DA14531 SmartBond TINY Module