DA14531

ADC Continuous mode bug in DA14531

Tue, 2021-01-26 15:00 -- wanhuaqifang

Hi dialog pm,

While I`m using DA14531`s ADC in continuous mode with BLE Enabled, I founded it will auto close after 2 seconds when I turn it on.

I founded that in "arch_system.c" a function called conditionally_run_radio_cals(); always enable ADC to check die temperature and re-cablirate the RF if temperature difference is greater than (or equal to) 8 degrees Celsius.

This operation will call "adc_init()" and turn off the ADC Interrupt.

Timer1 configuration of prox_reporter causes dramatic power increase

Tue, 2021-01-26 01:35 -- andrewl

Hi, folks,

 

I can set the prox_reporter project to do advertising timeout and go to extended sleep.  This is fine--the advertising does a couple of bursts and then goes to extended sleep.  I get somewhere around 1.6uA of current or so.

 

However, if I set "CFG_EXT_SLEEP_WAKEUP_TIMER1" and change *nothing else*, I get mA spikes at the advertising interval and it never stops.  That's no good.  It seems like timer1 is resetting the fact that the advertising is supposed to have timed out.

 

How do I avoid that?

 

Thanks.

 

simple_beacon_example does not work with SDK 6.0.14.1114

Tue, 2021-01-26 01:03 -- andrewl

When I run the

 

python dlg_make_keil5_env_v1.006.py -sdkpath "c:\\sdk\\dialog\\6.0.14.1114\\"

 

I get: 

"FileNotFoundError: [Errno 2] No such file or directory: 'c:\\\\sdk\\\\dialog\\\\6.0.14.1114\\sdk\\common_project_files\\scatterfiles\\scatterfile_common.sct'"

 

This doesn't happen with 6.0.12.

 

Thanks.

 

 

Extended Sleep Peripheral (non-BLE) example?

Mon, 2021-01-25 11:13 -- andrewl

Hi, folks,

 

I have a project that needs to wake up roughly every 15ms, do some basic GPIO stuff, and then go back to sleep.  No BLE needed.  Presumably I need to be in extended sleep mode so that I can use Timer1 to wake me up (I sure don't want to be reloading from OTP/Flash every 15ms) with RAM retention.

 

We already have a custom board built so we can avoid the issues with trying to get power numbers and having the dev kit driver board getting in the way.

 

Flash Download Failed with USB Dev. kit

Mon, 2021-01-25 07:55 -- ikuyama

Hi,
I tried writeing sample code according to the tutorial (UM-B-117).
But I fail with flash write. The error message is as follows.

--------------------------
No Algorithm found for: 07FC0000H - 07FC100BH
Erase skipped!
Error: Flash Download failed  -  "Cortex-M0+"
Flash Load finished at 16:37:12
---------------------------

I changed device setting to "DA14531" and tried once again. but also failed.
Do I need any settings at "Flash Download" tag.
Please give me some advices.

Thanks
 

SmartSnippets Toolbox won't program SPI Flash

Mon, 2021-01-25 04:53 -- andrewl

Hi, folks,

 

I have a custom board that we've designed and been checking out.  I can boot the DA14531 to RAM using either Keil SWD via my Segger J-Link or SmartSnippets Toolbox 1-Wire UART.  It works fine.

 

The problem is that I can't get the SmartSnippets Toolbox v5.0.14.3080 to program the SPI flash.  It fails with "[ERROR    General            @21-01-24 22:39:22] No known chip found while opening JLink connection. Terminating proccess...".  This makes no sense as the chip programs via Keil SWD just fine.

 

USB开发板烧录仅适用于Pro开发板的例程后,无法再识别芯片

Mon, 2021-01-25 03:43 -- 紫炎灬裂天

我的同事将“DA14531-DA14585-586_Reading_I2C_Accelerometer_BLE”例程烧录到USB开发套件上了,之后电脑无法检测到da14531了。目前来看,I2C的两个引脚定义和板载SPI_flash和SWD的引脚有冲突,例程user_periph_setup.h文件如下:

#define I2C_SCL_PORT                GPIO_PORT_0
#define I2C_SCL_PIN                 GPIO_PIN_2

#define I2C_SDA_PORT                GPIO_PORT_0
#define I2C_SDA_PIN                 GPIO_PIN_1

 

想请教下:

①有简单的办法恢复开发板吗?

②只要注意不与SPI_FLASH、SWD接口产生冲突,就可以在自制板/USB开发板上适配这个例程吗?还是另有注意事项

wake on HW interrupt - which example?

Sat, 2021-01-23 18:17 -- 3hl3rt

Hello,

 

I have to make an extremly simple app:

Device will be at sleep 99.99% of the time, but when a HW button is pressed, it should wake up, wait for the phone to connect, and then send a small payload  (4Bytes)

it should return to sleep afterwards, and would also need to make a timeout in case the phone never connects.

 

but I am unsure which example to start with - I am on eclipse, but basically only the prox_reporter projects runs out of the box - but I would just like some hints here to look.

 

best regards,

 

Pages

Subscribe to RSS - DA14531