DA14531

Simple multithreading with DA14531

Tue, 2020-12-08 16:14 -- joachimkr

Hello,

I have written an application with Keil IDE, transferring RFID reader results by notification of a subscribing node. The reader is part of my hardware system. Hardware handling is started, after a client requested to be notified by value change on his reader.
That is working, but it blocks any other activity.
Now, I need a hint / simple example, how I can accomplish the following:

About DA14531 hardware reset and FLASH hardware design issues

Tue, 2020-12-08 13:01 -- MrWeng

The attachment is the schematic diagram of DA14531 connecting flash, which I designed, is this connection method correct? If it is not correct, may the DA14531 connect to the flash must be connected as follows and cannot be changed? P0_0 is connected to SI, P0_1 is connected to CS#, P0_3 is connected to SO, and P0_4 is connected to SCLK.

Programming OTP with JTAG

Wed, 2020-12-02 19:18 -- mbwjr12

Dear Dialog,

Are there examples for programming the OTP directly with a JTAG debugger? We have our own production setup where it is preferable to program over SWD instead of a UART download.

 

I am familiar with the OTP layout of the Smart Snippets Toolbox which is what we are currently using. I am looking for something like a JLink script to burn the hex file to OTP and set both application programmed flags to true in one quick step.

 

Thanks,

Mike

DA14531 bricked after programming

Mon, 2020-11-23 14:36 -- paolog

Hi!

I started programming the DA14531 using the USB Development Kit. I'm working on the SDK examples and using the standalone flash programmer. All good, until I possibly did something wrong in the modifications, and I'm currently unable to access the DK. The JTAG is recognized when the USB DK is connected, but the DA14531 is not replying (tried with Keil 5). I also tried the 1-wire boot, but the reply is "wrong CRC" after pressing the reset button. Is there a way to recover that board?

Pages

Subscribe to RSS - DA14531