DA1468x

DA14681 HardFault when reading I2C sensor via I2C Adapter

Wed, 2020-10-14 21:03 -- mahmed106

Hi Dialog

We are working on a custom board based on DA14681 and a unusual problem occured.

We are currently testing 4 to 5 boards with same hardware and same firmware. But only one of them is restarting and upon debugging we found out that, that particular is going into hard_fault state. Upon more debugging it is found that when ad_i2c_write() is called, it goes into hard fault state.

Two wierd things regarding this : 
1 - it is only happening on one board out of 5 boards, same hardware same firmware.

How to specify custom uartboot.bin to cli_programmer when running an external tool

Tue, 2020-10-13 19:46 -- asteriskSF

I am working on a custom board with a 32MHZ external crystal.  In order to use the cli_programmer with this custom board and crystal, a modified uartboot.bin second stage bootloader is required.  When operating from the command line this can be accomplished with -b option.   I have built the custom bootloader and moved it to binaries/uartboot_XTAL_32MHZ.bin  

Is there a recommended method for program_qspi_jtag_win.bat and other similar external tool scripts (e.g. erase_qspi_jtag_win) to pass parameters to cli_programmer?

 

Switch from DA14680 to DA14682

Fri, 2020-10-09 08:53 -- ghschwab

Hi,

for a slight redesign of an existing project, we wanted to switch to DA14682 from DA14680. First, I tried to program the hardware from the existing SmartSnippets Studio (v1.6.3.981) with SDK 1.0.10. As I received errors while trying to program, I downloaded the newer SDK (1.0.14) and imported the corresponding scripts. The first time I tried to program, it showed the device selection, and after selecting the correct processor, I was able to program the device. However, when trying to debug the project, I always get stuck in the reset handler.

SUOTA Partition table difference

Fri, 2020-10-02 00:29 -- dlo
PARTITION2( 0x000000 , 0x01E000 , NVMS_FIRMWARE_PART        , 0 )
PARTITION2( 0x01E000 , 0x001000 , NVMS_PRODUCT_HEADER_PART  , 0 )
PARTITION2( 0x01F000 , 0x001000 , NVMS_IMAGE_HEADER_PART    , 0 )
PARTITION2( 0x020000 , 0x050000 , NVMS_FW_EXEC_PART         , 0 )
PARTITION2( 0x070000 , 0x00D000 , NVMS_LOG_PART             , 0 )
PARTITION2( 0x07D000 , 0x002000 , NVMS_PLATFORM_PARAMS_PART , PARTITION_FLAG_READ_ONLY )
PARTITION2( 0x07F000 , 0x001000 , NVMS_PARTITION_TABLE      , PARTITION_FLAG_READ_ONLY )
PARTITION2( 0x080000 , 0x010000 , NVMS_PARAM_PART           , 0 )

hw_aes_hash_store_keys() in secured mode ?

Thu, 2020-09-24 09:34 -- bobspam@free.fr

Hello

I am using AES CBC to transmit data from the DA14683 and I would like to prepare my code for secured mode. I do understand from documentation that in order to set AES keys, I do need to:

- enable OTP for reading

- use DMA channel 7 to transfer keys from OTP to AES KEY 64 registers

- disable OTP

- launch AES on my data

I whish to get more insight about hw_aes_hash_store_keys function that I am currently using to prepare AES coprocessor. It sets key expansion and prepare key bytes before transfering it to the AES registers.

DA14681 SOC, power circuit fails?

Wed, 2020-09-23 17:02 -- mahmed106

Hi dialog

we are working on a custom board based on DA14681. Actually our product is old and is been in the market for over 2 years. But recently we have faced an issue that some of our boards that were ccompleted and tested by the production team. After around 2 years we have tested them and they are not working.

Pages

Subscribe to RSS - DA1468x