error compiling Multiperipheral_Example project

⚠️
Hi there.. thanks for coming to the forums. Exciting news! we’re now in the process of moving to our new forum platform that will offer better functionality and is contained within the main Dialog website. All posts and accounts have been migrated. We’re now accepting traffic on the new forum only - please POST any new threads at https://www.dialog-semiconductor.com/support . We’ll be fixing bugs / optimising the searching and tagging over the coming days.
10 posts / 0 new
Last post
koukou
Offline
Last seen: 7 months 3 weeks ago
Joined: 2019-10-14 10:42
error compiling Multiperipheral_Example project
I am trying to compile the SW example: DA14531- DA14585-586_Multiperipheral_Example. but it shows an error.

 

I am trying to run the python script in order to link them to the SDK. but it also displays an error.

 

 

Device: 
PM_Dialog
Offline
Last seen: 1 month 5 days ago
Staff
Joined: 2018-02-08 11:03
Hi koukou,

Hi koukou,

Can you please indicate the SDK version that you are using in order to link the SW Example with the SDK?

Thanks, PM_Dialog

koukou
Offline
Last seen: 7 months 3 weeks ago
Joined: 2019-10-14 10:42
 

 

I used the sdk 6.0.14.1114 and the sdk 6.0.10.511 but there is an error during the execution of the python script in both cases

 

PM_Dialog
Offline
Last seen: 1 month 5 days ago
Staff
Joined: 2018-02-08 11:03
Hi There,

Hi There,

Please try to download again the DA14585/DA14586 - DA14531 Multiperipheral Example and the SDK6.0.14.1114 for DA14531 and DA14585/6. I would recommend using a clean SDK directory in order to execute the python script.

After that extract the zip file, open a terminal and run:

> cd <example folder>/project_environment

> python dlg_make_keil5_env_v2.000.py -sdkpath “<path to your sdk repository>”

For instance:

> python dlg_make_keil5_env_v2.000.py -sdkpath “C:\dev\6.0.14.1114”

I tried in my side and I am able to link the SW example with the SDK.

If toy still have problems with the linking, please share a screenshot from the terminal.

Thanks, PM_Dialog

koukou
Offline
Last seen: 7 months 3 weeks ago
Joined: 2019-10-14 10:42
here is a screenshot of the
here is a screenshot of the terminal.
Attachment: 
PM_Dialog
Offline
Last seen: 1 month 5 days ago
Staff
Joined: 2018-02-08 11:03
Hi koukou,

Hi koukou,

What is the version of the Python that you have installed in your PC?

Thanks, PM_Dialog

koukou
Offline
Last seen: 7 months 3 weeks ago
Joined: 2019-10-14 10:42
python 3.5(64 bit)

python 3.5(64 bit)

PM_Dialog
Offline
Last seen: 1 month 5 days ago
Staff
Joined: 2018-02-08 11:03
Hi There,

Hi There,

In my side I am using Python version 3.7.1. Can you please give a try with that version? Additionally, are you able to link any oyther SW Example with the SDL6.0.14?

Thanks, PM_Dialog

koukou
Offline
Last seen: 7 months 3 weeks ago
Joined: 2019-10-14 10:42
 

 

when i used python 3.7.1 i managed to link the SW example to the SDK. now when i launched the project i get this error

Attachment: 
PM_Dialog
Offline
Last seen: 1 month 5 days ago
Staff
Joined: 2018-02-08 11:03
Hi There,

Hi There,

Please take a look at the attached screenshots and make sure that you have the same configurations. The initialization file located under ..\..\..\6.0.14.1114\sdk\common_project_files\misc\sysram_case23.ini.

Thanks, PM_Dialog

Attachment: