⚠️
Hi there.. thanks for coming to the forums. Exciting news! we’re now in the process of moving to our new forum platform that will offer better functionality and is contained within the main Dialog website. All posts and accounts have been migrated. We’re now accepting traffic on the new forum only - please POST any new threads at https://www.dialog-semiconductor.com/support . We’ll be fixing bugs / optimising the searching and tagging over the coming days.
8 posts / 0 new
Last post
UO251410
Offline
Last seen: 1 year 4 months ago
Joined: 2020-07-09 09:54
Error in flash programmin

Hello

I'm using smart snippets flash programing option to download my firmware on a DA14585 by JTAG connection. I follow all the instructions on here: https://www.dialog-semiconductor.com/sites/default/files/an-b-055_-_da14585_interfacing_with_external_memory_1.5.pdf but I can't do it properly. The log console shows "Succesfully download firmware file to the board", but the led does not blink and if I scan ble devices with the app there is nothing. If I try with the booter option with the same .bin file it works properly.

Has anybody any idea of what can be happening?

 

Thanks

Device: 
PM_Dialog
Offline
Last seen: 2 days 9 hours ago
Staff
Joined: 2018-02-08 11:03
Hi UO251410,

Hi UO251410,

Thanks for your question online but it would be very helpful to clarify couple of things in order to have a better view on you issue.  So please indicate:

-          The board that you are using ( is it custom board or any of Dialog Developments Boards? )

-          The SDK version and which SDK example

-          Did you run it in debug mode first to make sure that is running properly?

-          When burning the binary image o the SPI Flash, did you make it bootable?

-          What is the version of Smart Snippets Toolbox?

Thanks, PM_Dialog

UO251410
Offline
Last seen: 1 year 4 months ago
Joined: 2020-07-09 09:54
The board that you are using

The board that you are using ( is it custom board or any of Dialog Developments Boards? )

I use the board contained in the DA145858 IOT MSENSkt IoT Multi Sensor kit (the DA14585 IOTMSENS sensor and the "multi purpose add-on sensor boar")

-          The SDK version and which SDK example

v6.160.4 and the IOT585 example

-          Did you run it in debug mode first to make sure that is running properly?

No, but if I use the booter it works properly. The modification I did in the code was defining the "ALWAYS_ADVERTISE". But I tried also without making any change. 

-          When burning the binary image o the SPI Flash, did you make it bootable?

Yes

-          What is the version of Smart Snippets Toolbox?

SmartSnippets Studio V2.0.10 for Windows OS

PM_Dialog
Offline
Last seen: 2 days 9 hours ago
Staff
Joined: 2018-02-08 11:03
Hi There,

Hi There,

Please use Keil IDE, download the FW into the System-RAM with the debugger attached and try to find it if gets stuck anywhere (WDOG expatiation / assertion /  NMI etc.).

Can you detect the device in the air? Is it adverting?

Thanks, PM_Dialog

UO251410
Offline
Last seen: 1 year 4 months ago
Joined: 2020-07-09 09:54
The problem is not the FW,

The problem is not the FW, because with de booter I can connect to the sensor and read temperature, humidity ... The problem is to download the FW to the sensor with the flash programming.

PM_Dialog
Offline
Last seen: 2 days 9 hours ago
Staff
Joined: 2018-02-08 11:03
Hi There,

Hi There,

>>> The problem is to download the FW to the sensor

Can you please clarify it? If you burn the SPI flash with the IoT firmware, is it running correctly?

Thanks, PM_Dialog

UO251410
Offline
Last seen: 1 year 4 months ago
Joined: 2020-07-09 09:54
I finally achieve to do it. I

I finally achieve to do it. I had to uncheck "Bootable" and use de multi_iot585.bin file.

PM_Dialog
Offline
Last seen: 2 days 9 hours ago
Staff
Joined: 2018-02-08 11:03
Hi There,

Hi There,

Glad that you figured your issue out and thanks for the indication.

Thanks, PM_Dialog