⚠️
Hi there.. thanks for coming to the forums. Exciting news! we’re now in the process of moving to our new forum platform that will offer better functionality and is contained within the main Dialog website. All posts and accounts have been migrated. We’re now accepting traffic on the new forum only - please POST any new threads at https://www.dialog-semiconductor.com/support . We’ll be fixing bugs / optimising the searching and tagging over the coming days.
4 posts / 0 new
Last post
alecerizza
Offline
Last seen: 8 months 2 weeks ago
Joined: 2020-11-03 14:12
Missing JTAG Communication DA14531

Hello, We are realizing a little board with DA14531 so to add BLE interface to our products. On 10 first samples rrealized only one is able to be programmed via JTAG interface using SmartSnippets Toolbox.

The error is a missing communication:

   ...

   Could not measure total IR len. TDO is constant high.

   No known chip found while opening JLink connection. Terminating proccess...

It appears like a soldering issue. With an XRAY control the solder of DA14531 does have some less tin and uneven solder, but it is difficult to judge whether all the solders are open-circuit.

I would like to ask you if you think this issue in your opinion depends only on soldering or if you suggest other controls.

Do you have any suggestion about the soldering process (e.g. temperature profile)?

Would you be available to check schematic and layout?

Thank you in advance.

 

 

Device: 
PM_Dialog
Offline
Last seen: 2 hours 35 min ago
Staff
Joined: 2018-02-08 11:03
Hi alecerizza,

Hi alecerizza,

Thanks for your forum post. Can I ask if you are using the Pro-DK to program your board via JTAG, or you are using an external JTAG interface?

Thanks, PM_Dialog

alecerizza
Offline
Last seen: 8 months 2 weeks ago
Joined: 2020-11-03 14:12
Hi, I'm using the Development

Hi, I'm using the Development Kit Pro to program via JTAG.

Thanks.

PM_Dialog
Offline
Last seen: 2 hours 35 min ago
Staff
Joined: 2018-02-08 11:03
Hi alecerizza,

Hi alecerizza,

Can you please check if you are using the correct jumpers and wiring configuration? See section 18.2. DA14531 PRO Development Kit :

http://lpccs-docs.dialog-semiconductor.com/Tutorial_SDK6/debug_probe.html

I would also suggest you to use short jumper wires for the JTAG connections. If using long jumper wires you may have to reduce the SWD clock speed due to the increased capacitance these add to the interface.

Thanks, PM_Dialog