Prod_Test Binaries Not Working on Dev Board JTAG?

⚠️
Hi there.. thanks for coming to the forums. Exciting news! we’re now in the process of moving to our new forum platform that will offer better functionality and is contained within the main Dialog website. All posts and accounts have been migrated. We’re now accepting traffic on the new forum only - please POST any new threads at https://www.dialog-semiconductor.com/support . We’ll be fixing bugs / optimising the searching and tagging over the coming days.
5 posts / 0 new
Last post
tim.payne1
Offline
Last seen: 1 year 3 months ago
Joined: 2020-01-27 16:53
Prod_Test Binaries Not Working on Dev Board JTAG?

Hi,

I have DA14585 Dev Kit, and am loading the prod_test binaries for RF testing:  ...6.0.14.1114\binaries\da14585\prod_test.

When I got to RF Master, and select JTAG, it appears the binaries are flashed to the dev board.

However, when I select continious TX we do not set any output in front of a spectrum analzyer.

Is there a reason flashing prod_test_585.hex to the dev board through JTAG would not work wth RF Master like this?

Device: 
KB_Dialog
Offline
Last seen: 1 day 13 hours ago
Staff
Joined: 2020-01-20 09:45
Hi tim.payne1

Hi tim.payne1

Which version of SStoolbox are you using?

Can you share the log file please.

Thanks,

BR,

KB_Dialog

tim.payne1
Offline
Last seen: 1 year 3 months ago
Joined: 2020-01-27 16:53
Hi,

Hi,

We have SmartSnippets Tool Box 5.0.6.2196;  I have attached log file below.

No errors are presented upon JTAG upload of prod_test_585.hex to DA14585 Dev board; and when continous TX is is selected, no errors are returned.

However there is no spectrum output.

Attachment: 
KB_Dialog
Offline
Last seen: 1 day 13 hours ago
Staff
Joined: 2020-01-20 09:45
Hi tim_payne1,

Hi tim_payne1,

Great, thanks. I can see that the DA14585 dones't respond to the command to cont_Tx command. I've reproduced the same on my dev board.

Let me investigate and get back to you.

BR,

KB_Dialog

KB_Dialog
Offline
Last seen: 1 day 13 hours ago
Staff
Joined: 2020-01-20 09:45
Hi tim.payne1,

Hi tim.payne1,

A quick workaround would be to use the prod_test binary from SDK6.0.10
C:\Users\KB_Dialog\SDK\SDK_6.0.10.511\binaries\da14585\prod_test\prod_test_585.hex

BR,

KB_Dialog