DA14531-DA14585-586_Reading_I2C_Accelerometer_BLE code example not working

2 posts / 0 new
Last post
Sanket Hiremath
Offline
Last seen: 1 year 8 months ago
Joined: 2020-09-16 08:23
DA14531-DA14585-586_Reading_I2C_Accelerometer_BLE code example not working

Hello,

I'm trying to get the example code "DA14531-DA14585-586_Reading_I2C_Accelerometer_BLE" to work but it is not the microcontroller is not able to read the data from the sensor at all..I have set up the keil environment properly according to the documents on the dialog semi website and I have set the correct i2c address for the ADXL345 (0x53) in the folder "user_ADXL345.h". I tried to debug the code by putting a break point in the function "int16_t ADXL345_read_X(void)" and the i2c read command " i2c_master_receive_buffer_sync(&byte_received, 1, &abort_code, I2C_F_NONE);" returns an error code  "I2C_ABORT_7B_ADDR_NO_ACK ". I have attached the screenshot of the debug window.. I even tried interfacing  HMC5883L digital compass but I'm facing the same issue for this compass as well.please help me resolve this issue.

 

DEVICE- DA14531 USB dev board

SENSOR-ADXL345

PINS CONNECTED- sda-01, scl-03

Attachment: 
Device: 
Martin.Ge
Offline
Last seen: 1 year 6 months ago
Staff
Joined: 2020-01-06 06:51
Hi Sanket, 

Hi Sanket, 

Could you please provide your compiling environment conditions with more details? 

And the DA145xx Pro Development Kit is needed for this example. 

USB dev board might not be sufficient for this demo. 

Also please following the SW/HW settings described in the file named "readme"

Br

Martin