Custom board using DA14682: JTAG not detected

⚠️
Hi there.. thanks for coming to the forums. Exciting news! we’re now in the process of moving to our new forum platform that will offer better functionality and is contained within the main Dialog website. All posts and accounts have been migrated. We’re now accepting traffic on the new forum only - please POST any new threads at https://www.dialog-semiconductor.com/support . We’ll be fixing bugs / optimising the searching and tagging over the coming days.
6 posts / 0 new
Last post
johrirj88
Offline
Last seen: 1 year 6 months ago
Joined: 2020-02-17 11:43
Custom board using DA14682: JTAG not detected

Hello,

          We have developed a custom hardware using DA14682 module and we are using an external JTAG from dialog semiconductor to flash the board. However the JTAG itself is not detected. Please let us know where we are going wrong.

 

Thanks and Regards

Raj Johri

Keywords: 
Device: 
PM_Dialog
Offline
Last seen: 6 months 4 weeks ago
Staff
Joined: 2018-02-08 11:03
Hi Raj Johri,

Hi Raj Johri,

Can I ask if you are using any of our DKs for the JTAG, or an external JTAG? If you are using any of Dialog DKs, could you please share how you have connected your custom board?

Thanks, PM_Dialog

johrirj88
Offline
Last seen: 1 year 6 months ago
Joined: 2020-02-17 11:43
We are taking JTAG from DK

We are taking JTAG from DK DA14695, to our custom designed board based on DA14682 (Image1, Image2 Attached). In the image we have shown that we are taking 5V from the JTAG, but later on we tried taking 3V supply instead of 5V, and we got the JTAG detected.

 

But now the JTAG is still unstable, sometimes detects the device sometimes it can't. Even when we are trying to flash we are getting two types of error randomly (Image3, Image4 attached). In this also error shown in Image3 gets more frequently. Please let us know what is going wrong.

 

Thanks and Regards

Raj Johri

PM_Dialog
Offline
Last seen: 6 months 4 weeks ago
Staff
Joined: 2018-02-08 11:03
Hi Raj Johri,

Hi Raj Johri,

>>>But now the JTAG is still unstable, sometimes detects the device sometimes it can't.

I assume that is not something wrong with the connections. Could you please try it with different cables? Do you have any other Dialog DK?

Thanks, PM_Dialog

johrirj88
Offline
Last seen: 1 year 6 months ago
Joined: 2020-02-17 11:43
Hi we have tried changing the

Hi we have tried changing the cables, but no effect.

Need to know few things:

1. Is "RST" (Reset) pin also required to be connected from JTAG to board for flashing?

2. What is the meaning of errors (-203) and (-304).

Please let us know about the above two points also.

Also is there any other thing that we are missing?

 

Thanks and Regards

Raj Johri

PM_Dialog
Offline
Last seen: 6 months 4 weeks ago
Staff
Joined: 2018-02-08 11:03
Hi Raj Johri,

Hi Raj Johri,

Do you have the Pro-DK? I would recommend using the Pro-DK instead of USB kit for programming your custom board.

I can see that the tools start programming you board but then the procedure is terminated. Please correct if I am mistaken.  I might be an issue with the SWD cable. Perhaps you might try shorted connection wires or try to reduce the communication speed.

You could also try to reset the board just before starting the firmware programming.

Thanks, PM_Dialog