RF Booster , RF Testing for DA1468x

Learn MoreFAQsTutorials

4 posts / 0 new
Last post
mahmed106
Offline
Last seen: 15 hours 52 min ago
Joined: 2019-05-03 17:28
RF Booster , RF Testing for DA1468x

Hi , i want to do RF Measurnment testing for my custom board, wihich contains DA14681 along with SKY66112-11. 

I am using Smartsnippets toolbox and PLT_FW firmware for testing. 

In code , main.c contains line 

hw_rf_set_tx_power(HW_RF_PWR_LUT_m3dbm);

and in file hw_rf.h , 5 levels are defined

typedef enum {
        HW_RF_PWR_LUT_0dbm = 0,   /**< TX PWR attenuation 0 dbm */
        HW_RF_PWR_LUT_m1dbm = 1,  /**< TX PWR attenuation -1 dbm */
        HW_RF_PWR_LUT_m2dbm = 2,  /**< TX PWR attenuation -2 dbm */
        HW_RF_PWR_LUT_m3dbm = 3,  /**< TX PWR attenuation -3 dbm */
        HW_RF_PWR_LUT_m4dbm = 4,  /**< TX PWR attenuation -4 dbm */
} HW_RF_PWR_LUT_SETTING;

 

When in main.c i change the value from 0 to 4 dm i cant see any change in my rssi value. 

2ndly in datasheet of SKY66112-11, it has only 2 TX Power modes, so how come in firmware 5 power modes are defined but in actual only 2 modes can be used by the IC . 

If my understanding is wrong, please clarify.

Device: 
PM_Dialog
Offline
Last seen: 21 hours 40 min ago
Staff
Joined: 2018-02-08 11:03
Hi mahmed106

Hi mahmed106

Could you please let me know if this question is related with the following post that you have made?

https://support.dialog-semiconductor.com/forums/post/dialog-smartbond-bluetooth-low-energy-%E2%80%93-tools/what-sdk-rf-tools-command-line-interface

Did you use the RF Master? It would be very helpful if you can explain what you are trying to accomplish. I would recommend you to not modify the plt_fw.

Thanks, PM_Dialog

mahmed106
Offline
Last seen: 15 hours 52 min ago
Joined: 2019-05-03 17:28
No its not related with that

No its not related with that ,,, 
When i look at the firmware of PLT_FW , i see that there are 5 TX levels but SKY6611 FEM provides only 2 levels of transmisson. So how firmware is using 5 levels. I want to understand that.

PM_Dialog
Offline
Last seen: 21 hours 40 min ago
Staff
Joined: 2018-02-08 11:03
Hi mahmed106,

Hi mahmed106,

From you attached screenshot, I saw that you are using SDK1.0.8 which is a very old version of SDK and it is not currently supported. I would strongly recommend you to download and use the latest SDK which is version 1.0.14. In the plt_fw from SDK1.0.14, I am not able to find the code snippet for the SKY6611 that you have attached.

Thanks, PM_Dialog