Unable to properly run the demo "ble_app_profile".

6 posts / 0 new
Last post
Maurizio Malaspina
Offline
Last seen: 15 hours 23 min ago
Joined: 2019-01-16 21:40
Unable to properly run the demo "ble_app_profile".

Hello, I've a "DA14580 Development Kit - Pro" and I've just run the blinky demo built with Keil uVision V5.26.2.0 (so far so good...).
I tried to test Bluetooth connectivity, so I launch a built of the project for the "prox_reporter_580" target but I get an error:


linking...
.\out_580\prox_reporter_580.axf: error: L6002U: Could not open file .\..\..\..\..\..\sdk\platform\patch_code\DA14580\obj\atts_task.obj: No such file or directory
Not enough information to produce a FEEDBACK file.
Finished: 1 information, 0 warning, 0 error and 1 fatal error messages.
".\out_580\prox_reporter_580.axf" - 1 Error(s), 1 Warning(s).
Target not created.

How can I solve that?

If I enter debugging despite the error, the debug start on my board (I see the activity onm the red led too, not only the debug GUI that is running) but the bluetooth device is not visible neither to my Android phone (Huawey P9 Lite) nor to my laptop (NO USB DONGLE, native Bluetooth periferal: it's an ASUS N56JN).

What's happening?
Where can I find an updated documentation in order to run the examples on my board?

Thank you very much indeed in advance,
Maurizio

Device: 
PM_Dialog
Offline
Last seen: 20 hours 6 min ago
Staff
Joined: 2018-02-08 11:03
Hi Maurizio Malaspina,

Hi Maurizio Malaspina,

First of all, could you clarify the version of the SDK that you are working on? Be aware that the latest version of SDK, is the version 5.0.4. This version of SDK we are currently support. You get this error form Keil environment when trying to download firmware into the SysRAM? In order to download firmware into the SysRAM of DA14580 using Keil, you should built the project, then press the ”Start/stop debug session”. You can also find it in the “Debug menu”. After that you should press it again. After the build of your project using Keil, you don’t have to pass the .axf file through that utility, in the DA1458x\DA14580\SDK\DA1458x_SDK\5.0.4\projects\target_apps\ble_examples\prox_reporter\Keil_5\out_580 directory you will be able to find the corresponding .hex file. I would recommend you to have a look at the UM-B-049 document, Appendix F.

https://support.dialog-semiconductor.com/system/files/resources/UM-B-049%20DA1458x%20Getting%20started%20with%20Development%20Kit%20-%20Pro_v1.2_0.pdf

Thanks, PM_Dialog

Maurizio Malaspina
Offline
Last seen: 15 hours 23 min ago
Joined: 2019-01-16 21:40
Thank you very much indeed

Thank you very much indeed for the fast reply.

I'm working with the SDK 5.0.4. I get the error just during "building target (F7)" as you can see in the attached "SDK_5_0_4_ErrorScreen.PNG".
Using the previous version of the SDK 5.0.3 instead, all works fine: I can build the target and properly debug/run the code, using the RAM, as you suggested me ( see "SDK_5_0_3_BuildTartget_OK.PNG").
I hope you'll be able to reproduce the same behaviour I see here and send me a suggestion.

Thank you in advance again,
Maurizio

Attachment: 
PM_Dialog
Offline
Last seen: 20 hours 6 min ago
Staff
Joined: 2018-02-08 11:03
Hi Maurizio Malaspina,

Hi Maurizio Malaspina,

Unfortunately, I am not able to replicate your issue. I would suggest you to reinstall the tool and try to build the project in a clean SKD directory. Do you have this issue only with prox_reporter or with all our BLE examples? Also, could you please let me know if you are trying to default prox_reporter example of the SDK or you did any modifications?

Thanks, PM_Dialog

Maurizio Malaspina
Offline
Last seen: 15 hours 23 min ago
Joined: 2019-01-16 21:40
Thank you, I've downloaded

Thank you, I've downloaded again the SDK 5.0.4 and now all is properly working (without reinstalling the Keil IDE).
Strange... but OK!

PM_Dialog
Offline
Last seen: 20 hours 6 min ago
Staff
Joined: 2018-02-08 11:03
Hi Maurizio Malaspina,

Hi Maurizio Malaspina,

Glad that you figured your issue out. Probably the old SDK paths was invalid. If you found any of the above answer useful, please mark one of them as “accepted”

Thanks, PM_Dialog