Accidentally selected Treat as DA1468x 1.0.4 SDK on SmartSnippets Studio startup

Learn MoreFAQsTutorials

3 posts / 0 new
Last post
Alan Jones
Offline
Last seen: 1 year 8 months ago
Joined: 2016-07-28 16:34
Accidentally selected Treat as DA1468x 1.0.4 SDK on SmartSnippets Studio startup

I accidentally selected the Treat as DA1468x 1.0.4 SDK radio button on the SmartSnippets Studio startup dialog (v1.6.3.918), but do not want that. Where do I change that configuration information, or how do I get the startup dialog back so that the latest 1.0.12 SDK compiles as it did before for the DA1468x devices in Smart Snippets Studio?

Device: 
MT_dialog
Offline
Last seen: 2 weeks 4 days ago
Staff
Joined: 2015-06-08 11:34
Hi Alan,

Hi Alan,

The Smart Snippets will check in the current workspace for a configuration file, if the tool doesn't find the configuration file it will promt the user to select how the tool should handle the SDK, so whenever you select an empty workspace, you will get that prompt (Choose how to treat the SDK), but of for example you create a workspace folder, extact the 1.0.12 SDK and then point it as a SS workspace, then you wont be prompted to choose, since the SDK will have a configuration file for configuring the tool. But why Treat as DA1468x was the wrong option, are you going to use a 58x SoC ? The 58x currently uses only Keil tool, no GCC support for the 58x family.

Thanks MT_dialog

Alan Jones
Offline
Last seen: 1 year 8 months ago
Joined: 2016-07-28 16:34
Thank you for the explanation

Thank you for the explanation - that's very helpful. I understand the 58x currently only uses Keil (but am looking forward to GCC support), my main concern was what SmartSnippets was doing when I'm in a 1.0.10 or 1.0.12 SDK workspace, but I had selected the option that indicated the IDE should treat it as a 1.0.4 SDK. I have multiple customers/projects, so things get a little complex at times, and in some cases, different SDK releases/workspaces are involved, particularly if a project is being migrated to a newer SDK release.