cli_programmer not work

⚠️
Hi there.. thanks for coming to the forums. Exciting news! we’re now in the process of moving to our new forum platform that will offer better functionality and is contained within the main Dialog website. All posts and accounts have been migrated. We’re now accepting traffic on the new forum only - please POST any new threads at https://www.dialog-semiconductor.com/support . We’ll be fixing bugs / optimising the searching and tagging over the coming days.
4 posts / 0 new
Last post
SunXin
Offline
Last seen: 1 year 5 months ago
Joined: 2020-12-15 02:58
cli_programmer not work

Hi:

I want to download ble_adv Demo to DA14695-00HQDEVKT-U with SmartSnippets Studio v2.0.14.

Project has built correctly,But when I use Run > External Tools > program_qspi_jtag ,

There was erro about:

"PROGRAM QSPI
..
........................................................................................................................
.
.
........................................................................................................................
. ERROR:
. cli_programmer.exe" has exited with code: 4294967295"

I opened cli_programmer.exe,There was about:"serial port parameter not found"

However,I can connect EVK witch JTAG or UART in SmartSnippets Toolbox .

What should I do to fix the cli_programmer.exe?

Device: 
IM_Dialog
Offline
Last seen: 1 year 4 months ago
Joined: 2016-12-06 22:25
Hi SunXin,

Hi SunXin,

Are you running Smart Snippets Studio on Windows or Linux?

If you are using Windows do you have administrator rights?

Also, can you please copy and paste the entire contents of the Consolde window (after you try to program the board) to your reply?

Thanks

IM_Dialog

SunXin
Offline
Last seen: 1 year 5 months ago
Joined: 2020-12-15 02:58
Hi,Dialog,

Hi,Dialog,

It is  running on Windows,I have administrator but it is useless.

 Consolde window is that:

........................................................................................................................
..
.. PROGRAM QSPI
..
........................................................................................................................
.
.
........................................................................................................................
. ERROR:
. cli_programmer.exe" has exited with code: 4294967295

. call: "D:\2.Software\SDK_10.0.10.118\binaries\cli_programmer.exe" --save C:\Users\pengyu_yang\AppData\Local\Temp\tmpv4jjvar9
........................................................................................................................
.
.
........................................................................................................................
..
.. FINISHED
..
........................................................................................................................

Attachment: 
IM_Dialog
Offline
Last seen: 1 year 4 months ago
Joined: 2016-12-06 22:25
Thanks, We will investigate

Thanks, We will investigate this issue and get back to you. 

Can you try using the UART programming option rather than JTAG i.e. use program_qspi_serial.

Best regards

IM_Dialog