Problem downloading code with DA14531 Development kit USB

Learn MoreFAQsTutorials

12 posts / 0 new
Last post
tamram
Offline
Last seen: 1 day 21 hours ago
Joined: 2020-06-23 09:41
Problem downloading code with DA14531 Development kit USB

Hi all,

I recently got started with the DA14531-00FXDEVKT-U (Development Kit-USB) but I am unable to download code to it using Keil uVision. I'm using the examples that came with the SDK (tried blinky and UART).

I have been following the instructions as per http://lpccs-docs.dialog-semiconductor.com/UM-B-117-DA14531-Getting-Star... and the 'Options for Target' Dialog window is set properly.

Although debugging works (to an extent - I do not get UART printouts in my terminal emulator) with these; when I build the files and then press the 'Download' button (F8) I get the following error (no other output):

--- Error: failed to execute ' '

So I suppose my question is twofold:

1. Why do I not get UART printouts in my terminal emulator (which has been configured according to http://lpccs-docs.dialog-semiconductor.com/UM-B-117-DA14531-Getting-Star... )

2. How do I go about tracing where the --- Error: failed to execute ' ' error comes from and find a solution?

Thanks in advance for any help!

Device: 
PM_Dialog
Offline
Last seen: 21 hours 10 min ago
Staff
Joined: 2018-02-08 11:03
Hi talamram,

Hi talamram,

I would recommend first checking the Getting Started with SDK6 (HTML) .

Please see section 2 / Fig. 3 and ensure that you have the same configuration:

http://lpccs-docs.dialog-semiconductor.com/Tutorial_SDK6/preparing.html

In section 10, you will find steps how to use the UART for printing debugging information.

Thanks, PM_Dialog

tamram
Offline
Last seen: 1 day 21 hours ago
Joined: 2020-06-23 09:41
Thanks for the reply.

Thanks for the reply.

I can confirm that the configuration of my board is according to section 2 / Fig. 3

Currently, I am trying the example as layed out in http://lpccs-docs.dialog-semiconductor.com/Tutorial_SDK6/bd_name.html#bl...

However, it seems to me that this tutorial mentions files that don't exist in the sdk sample projects, namely:

user_peripheral_template.h
user_peripheral_template.c

This project does contain:

user_empty_peripheral_template.h
user_empty_peripheral_template.c

Thanks for any clarification on this. I am using SDK 6.0.14.1114

PM_Dialog
Offline
Last seen: 21 hours 10 min ago
Staff
Joined: 2018-02-08 11:03
Hi talamram,

Hi talamram,

Thanks for your finding! Could you please double check if you are following the proper steps?

If I am not mistaken, you are unable to perform step 6.1. Can you please run it in debug mode and add a BKPT in memcpy() ? Is the new device name mem-copied correctly?

Thanks , PM_Dialog

tamram
Offline
Last seen: 1 day 21 hours ago
Joined: 2020-06-23 09:41
Yes I have double checked

Yes I have double checked with a clean install of the SDK and have followed the proper steps.

I would suggest you check SDK_6.0.14.1114\DA145xx_SDK\6.0.14.1114\projects\target_apps\template vs the instructions in the tutorial. Also, is there a reason the tutorial does not state the enclosing folder of the files it mentions?

PM_Dialog
Offline
Last seen: 21 hours 10 min ago
Staff
Joined: 2018-02-08 11:03
Hi talamram,

Hi talamram,

I have followed steps 5 and 6. Can you please clarify again what is the problem? Is this one in your initial post?

The files can be found under the Project tree in the Keil IDE. However, I will ask if we can add the folders too.

Thanks, PM_Dialog

tamram
Offline
Last seen: 1 day 21 hours ago
Joined: 2020-06-23 09:41
The problem is that I can't

The problem is that I can't download a program to the target ;) I am trying out these tutorials, but I'm getting stuck at a pretty early stage.

Please see my screenshots of the file tree from Keil attached (all the user folders), the files  user_peripheral_template.h and user_peripheral_template.c are not present in the file tree.

 

 

 

Attachment: 
PM_Dialog
Offline
Last seen: 21 hours 10 min ago
Staff
Joined: 2018-02-08 11:03
Hi talamram,

Hi talamram,

Please use user_empty_peripheral_template.h / .c instead of user_peripheral_template.h / .c

Are you trying through the Keil IDE to download FW onto target? Are you getting any error?

Thanks, PM_Dialog

tamram
Offline
Last seen: 1 day 21 hours ago
Joined: 2020-06-23 09:41
Ok, I will use user_empty

Ok, I will use user_empty_peripheral_template.h / .c instead of user_peripheral_template.h / .c

Regarding downloading to the target; I am using KEIL IDE. And yes, I am getting an error, like I mentioned in my first post:

Although debugging works (to an extent - I do not get UART printouts in my terminal emulator) with these; when I build the files and then press the 'Download' button (F8) I get the following error (no other output):

--- Error: failed to execute ' '

Any idea what I am doing wrong here?

PM_Dialog
Offline
Last seen: 21 hours 10 min ago
Staff
Joined: 2018-02-08 11:03
Hi talamram,

Hi talamram,

Please share screenshots showing the steps and the error. I'd like to replicate it.

Thanks, PM_Dialog

tamram
Offline
Last seen: 1 day 21 hours ago
Joined: 2020-06-23 09:41
Thanks for the swift

Thanks for the swift responses. Unfortunately, I won't have access to the development kit until tomorrow. I will post back in approximately 24 hours; thank you!

PM_Dialog
Offline
Last seen: 21 hours 10 min ago
Staff
Joined: 2018-02-08 11:03
Hi talamram,

Hi talamram,

OK -  please share the screeonshots tomorrow!

Thanks, PM_Dialog