SmartSnippet [java.lang.NullPointerException] error everytime import a new project

⚠️
Hi there.. thanks for coming to the forums. Exciting news! we’re now in the process of moving to our new forum platform that will offer better functionality and is contained within the main Dialog website. All posts and accounts have been migrated. We’re now accepting traffic on the new forum only - please POST any new threads at https://www.dialog-semiconductor.com/support . We’ll be fixing bugs / optimising the searching and tagging over the coming days.
8 posts / 0 new
Last post
yingfen
Offline
Last seen: 2 years 10 months ago
Joined: 2019-08-07 00:10
SmartSnippet [java.lang.NullPointerException] error everytime import a new project

Hi everyone,

I am using the latest version of SmartSnippets (v2.0.7). Everytime I try to import a new project, it keeps showing an error [java.lang.NullPointerException], and I cannot build the project using the tool icon above (the icon is grey), but I can still build the project by right-click the project and it works.

And if I restart the software, the problem gets fixed automatically, until I import another project. Closing and reopening a project do not lead to the same problem, only importing does. And everything else works fine. What's possible reason for it?

Thanks!

Device: 
PM_Dialog
Offline
Last seen: 7 months 1 week ago
Staff
Joined: 2018-02-08 11:03
Hi yingfen,

Hi yingfen,

The latest version of SmartSnippets is v2.0.8 so I would suggest you download it for our support website and install. Does this issue exist with SmartSnippets version 2.0.8? If yes, please share me a screenshot with your issue? You could attach it in your forum thread.

Thanks, PM_Dialog

yingfen
Offline
Last seen: 2 years 10 months ago
Joined: 2019-08-07 00:10
Thanks for your reply.

Thanks for your reply.

I've updated it to v2.0.8 and the problem is exactly the same.

The attachment is restricted as pdf files, so I attach a link for the screenshot:

https://user-images.githubusercontent.com/32470088/63043634-3c703500-be92-11e9-8e07-649bb94c44f5.png

(Please let me know if you cannot open it)

Thanks!

MHv_Dialog
Offline
Last seen: 1 year 2 months ago
Staff
Joined: 2013-12-06 15:10
Hi yingfen,

Hi yingfen,

I have asked our customer support team to look into this issue. You should get a response in the next day or two.

/MHv

yingfen
Offline
Last seen: 2 years 10 months ago
Joined: 2019-08-07 00:10
Thank you very much! I will

Thank you very much! I will wait for it.

MHv_Dialog
Offline
Last seen: 1 year 2 months ago
Staff
Joined: 2013-12-06 15:10
Hi Yingfen,

Hi Yingfen,

We have apparently never observed this issue in the past. Our inhouse experts beleive that the following could be the cause and solution:

"It could be a corrupted workspace and cleaning the .metadata folder in the SDK could fix it."

If this does not resolve the issue, please provide a screenshot of the entire error message (the one you uploaded appered to be cropped at the bottom).

/MHv

yingfen
Offline
Last seen: 2 years 10 months ago
Joined: 2019-08-07 00:10
Thank you! So far it works

Thank you! So far it works well. I will keep an eye on it and may post another thread if the error appears again. Thanks again!

MHv_Dialog
Offline
Last seen: 1 year 2 months ago
Staff
Joined: 2013-12-06 15:10
Thanks for you feedback. I

Thanks for you feedback. I will let the team know that this fix seems to work. Let me know if you run into this issue again.

/MHv