SmartSnippets Studio V1.6.3 CLI -Erase Faillure

Learn MoreFAQsTutorials

8 posts / 0 new
Last post
dhirajp15
Offline
Last seen: 1 year 3 months ago
Joined: 2016-06-08 15:26
SmartSnippets Studio V1.6.3 CLI -Erase Faillure

Hi Dialog,
I recently updated smartsnipets studio from v1.2.3.588 to v1.6.3 and was trying to use command line interface to erase spi flash memory of da14583 using jlink:
Following error was observed:
C:\DiaSemi\SmartSnippetsStudio\Toolbox>SmartSnippetsToolbox.exe -type spi -clk P
2_0 -cs P2_3 -miso P2_4 -mosi P2_9 -chip DA14583-00 -jtag -1 -gpio P1_2 -firmwa
re common_resources/jtag_programmer.bin -cmd erase
Launching SmartSnippets Toolbox v 4.8.3.1804
TotalIRLen = ?, IRPrint = 0x..000000000000000000000000
TotalIRLen = ?, IRPrint = 0x..000000000000000000000000
Found SWD-DP with ID 0x0BB11477
FPUnit: 4 code (BP) slots and 0 literal slots
Found Cortex-M0 r0p0, Little endian.
BTLE device selected.
Found SWD-DP with ID 0x0BB11477
FPUnit: 4 code (BP) slots and 0 literal slots
Found Cortex-M0 r0p0, Little endian.
CPU could not be halted
Failed writing value A7 at address 50000012.
Failed downloading firmware file to the board.
Using default baudrate: 57600 Bd.
Failed clearing memory address 81FE8.
Failed setting the following values to SPI Flash gpios: CLK=P2_0, CS=P2_3, MISO=
P2_4, MOSI=P2_9.
Failed clearing memory address 81FE8.
SPI Flash memory erasing failed.

I reinstalled the older version (v1.2.3.588) and it worked fine .Result:
C:\DiaSemi\SmartSnippetsStudio\Toolbox>SmartSnippetsToolbox.exe -type spi -clk P
2_0 -cs P2_3 -miso P2_4 -mosi P2_9 -chip DA14583 -jtag -1 -gpio P1_2 -firmware
common_resources/jtag_programmer.bin -cmd erase
Found SWD-DP with ID 0x0BB11477
FPUnit: 4 code (BP) slots and 0 literal slots
Found Cortex-M0 r0p0, Little endian.
BTLE device selected.
Successfully downloaded firmware file to the board.
Using default baudrate: 57600 Bd.
Successfully set SPI Flash gpios: CLK=P2_0, CS=P2_3, MISO=P2_4, MOSI=P2_9.
SPI Flash memory erasing completed successfully.

Thanks ,
Regards,
Dhiraj

Device: 
MT_dialog
Offline
Last seen: 2 weeks 4 days ago
Staff
Joined: 2015-06-08 11:34
Hi dhjrap15,

Hi dhjrap15,

Just tested the erasing functionallity on a pro dev kit using the CLI, i dont see any issues, perhaps the reason was something else and not the SS Toolbox.

C:\DiaSemi\SmartSnippetsStudio\Toolbox>SmartSnippetsToolbox.exe -type spi -chip DA14583-00 -clk P2_0 -cs P2_3 -miso P2_4 -mosi P2_9 -jt
ag 480064769 -firmware common_resources/jtag_programmer.bin -cmd erase
Launching SmartSnippets Toolbox v 4.8.3.1804
Could not measure total IR len. TDO is constant high.
Could not measure total IR len. TDO is constant high.
Found SWD-DP with ID 0x0BB11477
FPUnit: 4 code (BP) slots and 0 literal slots
Found Cortex-M0 r0p0, Little endian.
BTLE device selected.
Using default GPIO pin Id: P1_2.
Found SWD-DP with ID 0x0BB11477
FPUnit: 4 code (BP) slots and 0 literal slots
Found Cortex-M0 r0p0, Little endian.
Firmware File common_resources/jtag_programmer.bin has been selected for downloading.
Successfully downloaded firmware file to the board.
Using default baudrate: 57600 Bd.
Successfully set SPI Flash gpios: CLK=P2_0, CS=P2_3, MISO=P2_4, MOSI=P2_9.
SPI Flash memory erasing completed successfully.

Thanks MT_dialog

dhirajp15
Offline
Last seen: 1 year 3 months ago
Joined: 2016-06-08 15:26
Hi MT_dialog ,

Hi MT_dialog ,
Looking at my results can you tell me what was the issue?

MT_dialog
Offline
Last seen: 2 weeks 4 days ago
Staff
Joined: 2015-06-08 11:34
Hi dhirajp15,

Hi dhirajp15,

Just looking the log of seems that the tool was even unable to download the the burning fw in the SoC it could be more of a jlink issue than a tool issue, but i can't be specific about this just by checking the error log.

Thanks MT_dialog

dhirajp15
Offline
Last seen: 1 year 3 months ago
Joined: 2016-06-08 15:26
Hi MT_Dialog ,

Hi MT_Dialog ,
The Jlink worked with SmartSnippets (v1.2.3.588) but not with latest version .So how it be a jlink issue. What other logs do you need to solve this problem ?
Regards,
Dhiraj

MT_dialog
Offline
Last seen: 2 weeks 4 days ago
Staff
Joined: 2015-06-08 11:34
Hi dhirajp15,

Hi dhirajp15,

In order to solve the issue i need to replicate it on my side, just from the jlink log i wont be able to give you a suggestion of what might went wrong and why your setup worked with the older version instead of the latest one, as mentioned on my side the Tool worked as it should. Also regarding the Jlink, the only think that led me to that assumption is the fact that from what you provide seems that the tool has issues when connecting to the board, each SST uses a different version of the jlink sw, so perhaps this is the issue. 

Thanks MT_dialog

dhirajp15
Offline
Last seen: 1 year 3 months ago
Joined: 2016-06-08 15:26
Hi MT_Dialog,

Hi MT_Dialog,
I am current using jlink with following specs:
Firmware: J-Link V9 compiled Mar 29 2018 17:46:13
Hardware: V9.20
Can you tell me the firmware & hardware version of jlink you are using ? Also the jlink requirement for Smartsnippetstudio version 1.6.3?
Regards,
Dhiraj

MT_dialog
Offline
Last seen: 2 weeks 4 days ago
Staff
Joined: 2015-06-08 11:34
Hi dhirajp15,

Hi dhirajp15,

The jlink i am using is Jlink v612j, the hardware is the one used on the Dialog dev kits:

Firmware: Jlink OB-SAM3U128 V1

Hardware: V1.00

If i am not mistaken the requirement for the Smart Snippets studio any future release from 6.12j and on.

Thanks MT_dialog