SmartSnippets Studio V1.6.3 CLI Issue :COM port is in use

Learn MoreFAQsTutorials

4 posts / 0 new
Last post
Louis Wang2
Offline
Last seen: 2 years 1 month ago
Joined: 2018-01-18 06:49
SmartSnippets Studio V1.6.3 CLI Issue :COM port is in use

Hi Dialog,
I recently updated smartsnipets studio v1.6.3 and was trying to use command line interface to erase/burn spi flash memory of da14585 using com-uart.
l have 20 DUTs and every DUT configured to different COM port . It is no problem to erase or burn one DUT at one time. But "COM is in use" would happened randomly at some DUTs when multiple DUTs run at the same time .Command line message shows connected COM port failed, COM is in use . Re-try or more re- try may passed.

logs:
C:\DiaSemi\SmartSnippetsStudio\Toolbox5\SmartSnippetsToolbox5.exe -type spi -chip DA14585-00 -com_port 9 -cmd erase -firmware C:\DiaSemi\SmartSnippetsStudio\Toolbox5\common_resources\flash_programmer_585.bin
Launching SmartSnippets Toolbox v 4.8.3.1804

Using default TxRx pair: P0_4, P0_5.
Connection to COM9 port has successfully opened.
Started download procedure...

***
Please press the hardware reset button on the board to start the download process.

Reset detected

***

***

***
Successfully disconnected from port COM9.
Successfully downloaded firmware file to the board.
Using default baudrate: 57600 Bd.
Connection to COM9 port has successfully opened.
Successfully disconnected from port COM9.
Successfully set SPI Flash gpios: CLK=P0_0, CS=P0_3, MISO=P0_5, MOSI=P0_6.
COM9 is in use. Please replug the board and try again.
Failed connecting to port COM9.
SPI Flash memory erasing failed.

Could you confirm my conclusion, that it is related to SmartSnippet or others ? How can I fixe it.

Best Regard!
Louis Wang

Device: 
PM_Dialog
Offline
Last seen: 19 hours 52 min ago
Staff
Joined: 2018-02-08 11:03
Hi Louis Wang2,

Hi Louis Wang2,

 

Could you please provide more information about the E-schematic with the connections?

Also, which CLI-commands are you using? It would be useful if you could provide an example of the CLI-command.

 

Thanks, PM_Dialog

Louis Wang2
Offline
Last seen: 2 years 1 month ago
Joined: 2018-01-18 06:49
Hi , Dialog

Hi , Dialog

l think this issue related to SmartSnippet , because we have project using DA14580 and use old version SmartSnippet (win32 ,v3.9) CLI to flash programming., it doesn't not has this issue. multiple DUTs (16) can run at the same time.
but using new SmartSnippet studio v1.6.3 CLI , "COM PORT is in use" would happened when multiple DUTs run at the same time.

PM_Dialog
Offline
Last seen: 19 hours 52 min ago
Staff
Joined: 2018-02-08 11:03
Hi Louis Wang2,

Hi Louis Wang2,

 

Could you please let me know what you exactly mean “at the same time” and what procedure you want to do in order to replicate your issue? Could you please provide more information about the connection diagram?

 

Thanks, PM_Dialog