Use Mesh USB kit as Normal Ble Device

⚠️
Hi there.. thanks for coming to the forums. Exciting news! we’re now in the process of moving to our new forum platform that will offer better functionality and is contained within the main Dialog website. All posts and accounts have been migrated. We’re now accepting traffic on the new forum only - please POST any new threads at https://www.dialog-semiconductor.com/support . We’ll be fixing bugs / optimising the searching and tagging over the coming days.
8 posts / 0 new
Last post
parmanjosan
Offline
Last seen: 2 years 8 months ago
Joined: 2018-01-26 13:58
Use Mesh USB kit as Normal Ble Device

Hello Dialog Team,

   I bought the USB Mesh kit from Mouser. But as a beginner, I saw- it is difficult to directly go in to mesh so now I started doing the tutorials of DA14683/2 BLE - "https://support.dialog-semiconductor.com/connectivity/product/da14682-and-da14683?qt-product_restricted_=3#qt-product_restricted_". So I have a question that - USB Mesh kit will work as normal BLE DA14683 kit?

 

  Because I burnt the Advertisement code without changing anything. It uploaded easily but the device is not showing on Mobile App. Why?

 

                                Waiting for your quick response 

Device: 
PM_Dialog
Offline
Last seen: 6 months 3 weeks ago
Staff
Joined: 2018-02-08 11:03
Hi parmanjosan,

Hi parmanjosan,

Once you have the QSPI Flash burnt with the mesh firmware, the device should start advertising. Could you please check if you follow the correct steps in order to burn the QSPI flash? Please check the below forum thread which might help you:

https://support.dialog-semiconductor.com/forums/post/dialog-smartbond-bluetooth-low-energy-%E2%80%93-tools/error-flashing-new-sw-sdk

Thanks, PM_Dialog

parmanjosan
Offline
Last seen: 2 years 8 months ago
Joined: 2018-01-26 13:58
Dear Dialog Team,

Dear Dialog Team,

   I think there is misunderstanding. Let me explain briefly -I bought "DA14683-00A9DEVKT-U" kit and I burnt the MSH SDK ("1.2"    "DA14682/DA14683 Mesh SDK"), code - "ble_mesh" easily and it works. then I took  "1.0.14.1081    DA1468x SDK1.0.14.1081" and code - "ble adv" It burnt easily on the same device but not working (No device is showing on my Android App). Then I took code - "freertos_retarget" from same sdk ("1.0.14.1081    DA1468x SDK1.0.14.1081") and it is also not working(Noting came in UART) .

                                      Waiting for your quick response 

parmanjosan
Offline
Last seen: 2 years 8 months ago
Joined: 2018-01-26 13:58
Dear Dialog Team,

Dear Dialog Team,

   I think there is misunderstanding. Let me explain briefly -I bought "DA14683-00A9DEVKT-U" kit and I burnt the MSH SDK ("1.2"    "DA14682/DA14683 Mesh SDK"), code - "ble_mesh" easily and it works. then I took  "1.0.14.1081    DA1468x SDK1.0.14.1081" and code - "ble adv" It burnt easily on the same device but not working (No device is showing on my Android App). Then I took code - "freertos_retarget" from same sdk ("1.0.14.1081    DA1468x SDK1.0.14.1081") and it is also not working(Noting came in UART) .

                                      Waiting for your quick response 

PM_Dialog
Offline
Last seen: 6 months 3 weeks ago
Staff
Joined: 2018-02-08 11:03
Hi parmanjosan,

Hi parmanjosan,

Apologies but I misunderstood your issue. Could you please try to erase the QSPI Flash and then program it with the ble_adv firmware?

Thanks, PM_Dialog

parmanjosan
Offline
Last seen: 2 years 8 months ago
Joined: 2018-01-26 13:58
Not working see the attached

Not working see the attached video 

parmanjosan
Offline
Last seen: 2 years 8 months ago
Joined: 2018-01-26 13:58
 

 

Dear Dialog Team,

 Thanks for the reply but Still issue remains the same it is not working see the attached video

PM_Dialog
Offline
Last seen: 6 months 3 weeks ago
Staff
Joined: 2018-02-08 11:03
Hi parmanjosan,

Hi parmanjosan,

Right click to the ble_adv project and then go to the “Properties”. Please check the attached photos in order to configure correctly the settings.

Workaround:

Change "${workspace_loc:/ble_stack/DA14683-00-Release}" to "../../../../../sdk/interfaces/ble_stack//DA14683-00-Release".

Since you have done these modifications, the errors should be disappeared. The warning will not be disappeared, but this will not be an issue and you can bypass it.  Please make these changes and then try to build your project.

Thanks, PM_Dialog