DA7212 ALC Noise Gate Problem

3 posts / 0 new
Last post
Shade234
Offline
Last seen: 2 hours 56 min ago
Joined: 2016-11-29 07:55
DA7212 ALC Noise Gate Problem

 Using the ALC with Noise Gate on the DA7212 - I'm seeing the noise gate work correctly on startup as the noise is not boosted until a level is reached.  However, after sound has activated the ALC, the noise level will not return to the original level (it seems the ALC is still applying some gain when it should have deactivated).  I attached an explanation with some pictures and a dump of the registers.  

    I've tried changing settings all sorts of settings (calibration modes, calibration type and calibration setup, digital/mixed ALC), and have reviewed the reference code.  

   I attached a short write-up with some pictures.  

   Any ideas or suggestions?

   Thanks!

Attachment: 
Device: 
ED_Dialog
Offline
Last seen: 21 hours 15 min ago
Staff
Joined: 2017-09-18 11:54
Hello,

Hello,

Someone from our local team will reach out directly.

Kind regards,
Elliott Dexter 

vpuri
Offline
Last seen: 2 weeks 6 days ago
Staff
Joined: 2018-01-10 00:50
Hello,

Hello,

This is a know limitation of the ALC for DA7212 where the ALC gain doesn't drop back to its inital value even though the input signal level has dropped. In case, the Codec is being used  in a voice call application turning on and off the ALC may reset the ALC gain registers for the next call .

Please email me on vaibhav.puri@diasemi.com and also CC wav.support@diasemi.com

Thanks,

Vaibhav