2 posts / 0 new
Last post
lyris85
Offline
Last seen: 3 weeks 16 hours ago
Joined: 2020-06-29 07:13
DA7212 devkit

hello,

I am trying to setup a configuration at 96khz. It works but I can hear some white noise on the output. Does the adc introduce some noise ?

 

I use the devkit ard-audio-DA7212.

 

Here is my i2c init:

DA7212_register_set(0x1D,0x80); //reset all reg
    DA7212_register_set(0xFD,0x1); //enable oscillator
    DA7212_register_set(0x22,0x0F); //96khz
    DA7212_register_set(0x27,0x04); //mclk between 10-20mhz
    DA7212_register_set(0x28,1); //64bclk/sample?
    DA7212_register_set(0x29,0xC8); //enable i2s
    DA7212_register_set(0x47,0xE1); //enable charge pump
    DA7212_register_set(0x30,0x30); //use aux gain L max
    DA7212_register_set(0x31,0x30); //use aux gain R max
    DA7212_register_set(0x34,0x0F); //use mix gain L max
    DA7212_register_set(0x35,0x0F); //use mix gain R max
    DA7212_register_set(0x32,0x01); //use auxin L
    DA7212_register_set(0x33,0x01); //use auxin R
    DA7212_register_set(0x4B,0x08); //use dac out L
    DA7212_register_set(0x4C,0x08); //use dac out R
    DA7212_register_set(0x60,0x80); //enable aux L
    DA7212_register_set(0x60,0x80); //enable aux R
    DA7212_register_set(0x65,0x88); //enable mixin L
    DA7212_register_set(0x66,0x88); //enable mixin R
    DA7212_register_set(0x67,0x80); //enable ADC L
    DA7212_register_set(0x68,0x80); //enable ADC R
    DA7212_register_set(0x69,0x88); //enable DAC L
    DA7212_register_set(0x6A,0x88); //enable DAC R
    DA7212_register_set(0x6B,0x88); //enable HP L
    DA7212_register_set(0x6C,0x88); //enable HP R
    DA7212_register_set(0x6E,0x88); //enable mixout L
    DA7212_register_set(0x6F,0x88); //enable mixout R
    DA7212_register_set(0x91,1); //io voltage 3.3V
    DA7212_register_set(0x50,0xF0); //enable  path
    DA7212_register_set(0x51,0xF7); //enable  path

 

Greetings

 

Device: 
bmcadam
Offline
Last seen: 6 days 12 hours ago
Staff
Joined: 2015-09-16 16:25
Hello,

Hello,

Checked your settings and everything appears okay when using the evaluation board.

We shouldt't be experiencing any white noise.

What is the master clock you are supplying ?

For better support, please contact us on this email address wav.support@diasemi.com

Regards,

Barry