DIALOG7212 Beep generator doesn’t work after exiting standby mode

10 posts / 0 new
Last post
Argoetti
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-07-19 23:30
DIALOG7212 Beep generator doesn’t work after exiting standby mode

Beep generator works well before entering to standby.

After exiting standby mode there is audio but Beep generator doesn’t work.

Any recommendations ? 

 

void HP_Standby(bool set){

 if (true==set)

   DA7212_CLR_REG_BITS(DIALOG7212_SYSTEM_ACTIVE,DA7212_MASK_ACTIVE);// Standby

 else         

   DA7212_SET_REG_BITS(DIALOG7212_SYSTEM_ACTIVE,DA7212_MASK_ACTIVE);// active

}

 

Device: 
ED_Dialog
Offline
Last seen: 1 day 7 hours ago
Staff
Joined: 2017-09-18 11:54
Hello,

Hello,

I will look into this for you. Are you using the DA7212 Eval board?

Kind regards,
Elliott Dexter

Argoetti
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-07-19 23:30
I have the DA7212 Eval board,

I have the DA7212 Eval board, but we are using our hardware.

Please check the standby ON/OFF while generating Beep tone on the Eval board and let me know if the Beep is still working after exiting standby.

If yes, please send the script.

ED_Dialog
Offline
Last seen: 1 day 7 hours ago
Staff
Joined: 2017-09-18 11:54
Hello,

Hello,

Would you be able to send me your set-up script?

Kind regards,
Elliott

Argoetti
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-07-19 23:30
I don't have a set-up script

I don't have a set-up script , not using the Eval board

Argoetti
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-07-19 23:30
The setup for the beep

The setup for the beep generator works without the standby.

After entering to a standby end exit standby, the only part that doesn’t work is the beep generator.

It looks like a bug since all the other functions are operating and there is no need to configure the registers again.

Argoetti
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-07-19 23:30
void beep_preconfigure(void)

void beep_preconfigure(void)
{
//return;
  //DIALOG7212_HP_En(false);// disable DIALOG7212_HP

  //HP_Route_Setup_Aux_to_HP(LINEA);
  //HP_Route_Setup_Aux_to_HP(LINEB);
  
  DA7212_SetBits(DIALOG7212_MIXOUT_L_SELECT, DIALOG7212_MIXOUT_L_SELECT_DAC_L_MASK);
  DA7212_SetBits(DIALOG7212_MIXOUT_R_SELECT, DIALOG7212_MIXOUT_R_SELECT_DAC_R_MASK);
 
  DA7212_WriteRegister(0x69, 0x80);
  DA7212_WriteRegister(0x6a, 0x80);
  //DA7212_SetBits(DIALOG7212_DAC_L_CTRL, DIALOG7212_DAC_L_CTRL_ADC_EN_MASK);
  //DA7212_SetBits(DIALOG7212_DAC_R_CTRL, DIALOG7212_DAC_R_CTRL_ADC_EN_MASK);
  DA7212_WriteRegister(0x45, 0x6f);
  DA7212_WriteRegister(0x46, 0x6f);
  
  DA7212_WriteRegister(0x41, 0x88);
  DA7212_WriteRegister(0x42, 0x88); 
  DA7212_WriteRegister(0x44, 0x80); 
  
  DA7212_WriteRegister(0x48, 0x39); 
  DA7212_WriteRegister(0x49, 0x39); 
  
  // enable digital to DAC routing for tone generator
  DA7212_WriteRegister(0x21, 0x10);
  DA7212_WriteRegister(0x28, 0x81);
  DA7212_WriteRegister(0x29, 0x80);
  DA7212_WriteRegister(0x2A, 0x32);
  
  DA7212_WriteRegister(0x98, 0x01);
  DA7212_WriteRegister(0x99, 0x00);
  
  //PLL
  DA7212_WriteRegister(0x22, 0x05);
  DA7212_WriteRegister(0x26, 0x20);
  DA7212_WriteRegister(0x22, 0x05);
  DA7212_WriteRegister(0x27, 0xf0);
  DA7212_WriteRegister(0x94, 0x02);
  
  
  //DA7212_WriteRegister(DIALOG7212_DIG_ROUTING_DAC, DIALOG7212_DIG_ROUTING_DAC_R_RSC_DAC_R | DIALOG7212_DIG_ROUTING_DAC_L_RSC_DAC_L);
  //DA7212_WriteRegister(DIALOG7212_DAI_CLK_MODE, DIALOG7212_DAI_CLK_EN_MASK);
  //DA7212_WriteRegister(DIALOG7212_DAI_CTRL, DIALOG7212_DAI_EN_MASK);
  //DA7212_WriteRegister(0x21, 0x32);
  
  
  /************Tone Generation & Beep Registers************/
  DA7212_WriteRegister(DIALOG7212_TONE_GEN_CFG2, DIALOG7212_TONE_GEN_CFG2_SWG_SEL_SWG1_ONLY);
  DA7212_WriteRegister(DIALOG7212_TONE_GEN_CYCLES, DIALOG7212_TONE_GEN_CYCLES_BEEP_CYCLES_1);
 // DIALOG7212_HP_En(false);// disable DIALOG7212_HP
  //beep_preconfigure1();
}

ED_Dialog
Offline
Last seen: 1 day 7 hours ago
Staff
Joined: 2017-09-18 11:54
Hello,

Hello,

We have test the beep generator on our eval boards and cannot replicate the issue. I have attached the set-up script we used.

Can you ensure that before going into standby, that all audio paths are disabled including the Tone genarotor.

 

Kind regards,
Elliott

 

 

 

Attachment: 
Argoetti
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-07-19 23:30
Tone Generator and Standby

Tone Generator and Standby issue 

Exit from Standby generate a noise, I tried to disable the audio paths, but it doesn’t work as expected. Below is the code to set the CODEC into Standby, please send a tested code to enter and exit  Standby  and keep the tone working.   

 

void DA7212_Active(bool active){

  if (true==active)

  {

    DA7212_WriteRegister(DIALOG7212_SYSTEM_ACTIVE, 0x01);

  //DA7212_WriteRegister(DIALOG7212_HP_L_CTRL, DIALOG7212_HP_L_CTRL_AMP_EN_MASK | DIALOG7212_HP_L_CTRL_AMP_OE_MASK);

  //DA7212_WriteRegister(DIALOG7212_HP_R_CTRL, DIALOG7212_HP_R_CTRL_AMP_EN_MASK | DIALOG7212_HP_R_CTRL_AMP_OE_MASK);

    //DA7212_WriteRegister(DIALOG7212_SYSTEM_ACTIVE, 0x01);

   // HP_Route_Preconfigure();

    //Audio_Route_Init_HP_Route();

 }

  else

  {

    //DA7212_WriteRegister(DIALOG7212_HP_L_CTRL, 0);

    //DA7212_WriteRegister(DIALOG7212_HP_R_CTRL, 0);

    DA7212_WriteRegister(DIALOG7212_SYSTEM_ACTIVE, 0x00);

  }

}

Argoetti
Offline
Last seen: 3 months 2 weeks ago
Joined: 2019-07-19 23:30
Tone Generator and powerup

Tone Generator and powerup Issue

Upon powerup (no JLINK) the Tone Generator is not working!

The Tone Generator works only while the CPU is connected to a JLINK!

The only way to work around this issue is to reset the CPU again after powerup reset and initialized the CODEC again.

There are  no differences  between the registers values before and after the 2nd reset.