Issue getting 2 inputs working with the DA7217 dev board

11 posts / 0 new
Last post
rgoslin
Offline
Last seen: 1 month 3 weeks ago
Joined: 2019-06-12 14:58
Issue getting 2 inputs working with the DA7217 dev board

After messing with the register settings quite a bit i cant seem to figure out why I'm unable to get audio in both line mic1 and line mic2. I've been using USB PB REC as a starting point.  All of the input settings seem to indicate that both channels are enabled\.

Device: 
bmcadam
Offline
Last seen: 2 months 4 days ago
Staff
Joined: 2015-09-16 16:25
Hello,

Hello,

I have attached a script for reference for USB Record.

Are you sure it is the input side is the issue ? is the data changing on the I2S Dout Pin when signals are applied to the MIC's ?

Normally it is the setup of the PC that causes issues in the USB Record path ?

Attachment: 
bmcadam
Offline
Last seen: 2 months 4 days ago
Staff
Joined: 2015-09-16 16:25
Does your message imply you

Does your message imply you are able to one mic working ?

rgoslin
Offline
Last seen: 1 month 3 weeks ago
Joined: 2019-06-12 14:58
Yes, we only see audio

Yes, we only see audio through  one mic.

bmcadam
Offline
Last seen: 2 months 4 days ago
Staff
Joined: 2015-09-16 16:25
I would try using the script

I would try using the script attached, just tried this in the lab and worked fine with two mics.

rgoslin
Offline
Last seen: 1 month 3 weeks ago
Joined: 2019-06-12 14:58
Tried the attached code with

Tried the attached code with the same result.  See attached outputs.

bmcadam
Offline
Last seen: 2 months 4 days ago
Staff
Joined: 2015-09-16 16:25
Are you taking this out on

Are you taking this out on the headphone path to get your capture on the Oscilloscope ?

Is the path you want Mic to Hp ?

bmcadam
Offline
Last seen: 2 months 4 days ago
Staff
Joined: 2015-09-16 16:25
Attached a MIC to HP path,

Attached a MIC to HP path, which two Mic's out to the HP.

rgoslin
Offline
Last seen: 1 month 3 weeks ago
Joined: 2019-06-12 14:58
No change, I am using the

No change, I am using the line mic1 and line mic2 (jacks J16 and J18).  With J16 I seen no audio out of the Headphone L or R.

bmcadam
Offline
Last seen: 2 months 4 days ago
Staff
Joined: 2015-09-16 16:25
Try the attached Script, this

Try the attached Script, this uses Differential Inputs and Output is also Differential.

Is it always one specfic Mic Channel you are not seeing.

Registers 0x6C and 0x74 are the mixers that select where the signal is being brought from.

 

rgoslin
Offline
Last seen: 1 month 3 weeks ago
Joined: 2019-06-12 14:58
No change.  Do these scripts

No change.  Do these scripts utilize the sidetone or are both mic one and two routed back to the headphones in software / through the microcontroller?  I know the sidetone is only one channel. The connector I'm unable to get up is J16.