DA7212 No voice from ADC/DAC module

4 posts / 0 new
Last post
zaz
Offline
Last seen: 1 month 3 weeks ago
Joined: 2017-11-17 18:56
DA7212 No voice from ADC/DAC module

Hello,

I am using ARD-AUDIO-DA7212 shield to record voice from analog Mic and output to headphones.
I can successfully output voice to headphones by bypassing ADC/DAC modules (analog only).
But when I want to pass data over ADC/DAC modules (skipping DAI output) I can't hear nothing in headphones.
I saw that when SR register set to 8, 12 or 16kHz, nothing happens.
But when I set SR register to 44.1 or 48kHz, I hear only noise from headphones.
MCLK = 12MHz
PLL_CTRL = 0xC4
DAI = slave mode
DIG_ROUTING_DAC = 0x00

Please help me with proper codec Initialization.

Regards,

Device: 
ED_Dialog
Offline
Last seen: 21 hours 2 min ago
Staff
Joined: 2017-09-18 11:54
Hello Zaz,

Hello Zaz,

We have noted your issue, and we are currently trying to find a solution for you, I will post back when I have one.

Kind Regards,

Elliott Dexter 

wfallon
Offline
Last seen: 2 days 20 hours ago
Staff
Joined: 2014-03-06 13:54
Hi Zaz,

Hi Zaz,

Please find attached an example script (Stereo MIC 1 single ended to HP and DAI via ADC and DAC 12MHzSlaveMode32bit.pdf) that you can use as a reference for your own code.

If you need further support, please provide more detail about your system implementation, particularly around the clocking scheme you are using.

Best regards

Willie Fallon

zaz
Offline
Last seen: 1 month 3 weeks ago
Joined: 2017-11-17 18:56
Hi,

Hi,

Thank you for provided example. Finally I able to output voice from headphones.
I found that issue was in incorrect input clocks (BCLK/WCLK) supplied by external MCU and missing of additional level 2 system configuration (register 0x50 and 0x51).

Thank you for support.
Best regards.