10 posts / 0 new
Last post
Krutarth
Offline
Last seen: 6 years 11 months ago
Joined: 2015-07-09 19:57
OTP Programming

Hi,
I am getting errors while programing the otp via otp programmer tool from smart snippets. Following are the error logs. I am using JTAG for programming don't understand what this error suggests. Please guide me through the otp Programming for PAN1740 module.

[INFO @15-08-13 13:34:25] TotalIRLen = 0, IRPrint = 0x00
[INFO @15-08-13 13:34:25] TotalIRLen = 0, IRPrint = 0x00
[INFO @15-08-13 13:34:25] Found SWD-DP with ID 0x0BB11477
[INFO @15-08-13 13:34:25] FPUnit: 4 code (BP) slots and 0 literal slots
[INFO @15-08-13 13:34:25] Found Cortex-M0 r0p0, Little endian.
[INFO @15-08-13 13:34:25] BTLE device selected.
[INFO @15-08-13 13:36:29] Started reading 32768 bytes from memory.
[INFO @15-08-13 13:36:30] Reading has finished. Read 32768 bytes.
[INFO @15-08-13 13:36:38] Read 11728 bytes from file full_emb_sysram.bin.
[INFO @15-08-13 13:37:33] Started burning memory with 11728 bytes of data at address 0x40000.
[ERROR @15-08-13 13:37:33] Adddittional error info at address 0x81FEC (MSB first): FF FF FF FE
[ERROR @15-08-13 13:37:33] Memory burning failed.
[INFO @15-08-13 13:37:58] Started burning memory with 11728 bytes of data at address 0x40000.
[ERROR @15-08-13 13:37:58] Adddittional error info at address 0x81FEC (MSB first): FF FF FF FE
[ERROR @15-08-13 13:37:58] Memory burning failed.
[INFO @15-08-13 13:38:23] Started burning memory with 11728 bytes of data at address 0x40000.
[ERROR @15-08-13 13:38:23] Adddittional error info at address 0x81FEC (MSB first): FF FF FF FE
[ERROR @15-08-13 13:38:23] Memory burning failed.

Thanks and Regards

Krutarth
Offline
Last seen: 6 years 11 months ago
Joined: 2015-07-09 19:57
Thought this might help wit

Thought this might help wit the issue.While using CLI tool i get the following error on the Command prompt
Timeout while waiting to receive the most significant byte of packet length(1000 msecs)
Successfully disconnected from port COM6
OTP Memory burning failed

Thanks and Regards,

summer20100514
Offline
Last seen: 5 years 12 months ago
Guru
Joined: 2014-12-30 05:01
Do you attach 6.8V to the VPP

Do you attach 6.8V to the VPP pin before you burn OTP ?

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Krutarth,

Hi Krutarth,

Have you tried burning a daughter board using the pro-kit and Smart Snippets? Also what is the length of your jtag cable connection ?

Thanks MT_dialog 

Krutarth
Offline
Last seen: 6 years 11 months ago
Joined: 2015-07-09 19:57
Hi,

Hi,
Yes I do provide 6.8 volt Vpp before i start burning the OTP and length of my JTAG cable is about 15 cm. I have designed custom interface board and not using any kits for now for the panasonic module.

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Krutarth,

Hi Krutarth,

Can you try and reduce your jtag cable length to less than 5cm and let us know ? According to panasonic issues for this reason my occur when working with jtag.

Thanks MT_dialog

Krutarth
Offline
Last seen: 6 years 11 months ago
Joined: 2015-07-09 19:57
Alright will try and post the

Alright will try and post the results if problem persists.

Thanks and Regards,

Krutarth
Offline
Last seen: 6 years 11 months ago
Joined: 2015-07-09 19:57
Same problem persists even

Same problem persists even with 4cm cable . I cannot burn the OTP memory tried CLI tool as well as via smartsnippets. Can read the contents of the memory via smartsnippets.

Thanks and Regards,

Krutarth
Offline
Last seen: 6 years 11 months ago
Joined: 2015-07-09 19:57
Hi, I found the solution to

Hi, I found the solution to my problem.
Please consider the SWD-JTAG connection recommendations for connecting pull down resistor on SWCLK and pull up resistor on SWDIO lines or it won't work. Panasonic does not mention these anywhere in their design guide nor it is shown in example interface board schematic. It cost me a new interface board design but was finally able to Burn the OTP and OTP-Header. Sharing the link where i found these answer: -
http://www.support.code-red-tech.com/CodeRedWiki/HardwareDebugConnections
Please close this ticket.

Thanks and Regards,

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi Krutarth,

Hi Krutarth,

Thanks for sharing your foundings.

MT_dialog

Topic locked