Pairing the ble with computer

7 posts / 0 new
Last post
aihuazou
Offline
Last seen: 7 years 2 months ago
Joined: 2015-02-08 03:23
Pairing the ble with computer

Hi Dialog:
I use the mouse reference to design a BLE mouse, but I can't pair with the computer ThinkPad T540p, which embed the BLE receiver ,who can help me .
Thks

Device: 
Baswaraj
Offline
Last seen: 6 years 4 months ago
Joined: 2015-05-20 07:18
HI AIhuazou,

HI AIhuazou,

I am using the same device - DA14580 as yours, Can you please let me know what Emulator/debugger you are using to program the board. Kindly reply to me regarding this. I am using a J-Link segger but facing some issues. This is not related to your post but kindly let me know.

THanks,
BAswaraj

aihuazou
Offline
Last seen: 7 years 2 months ago
Joined: 2015-02-08 03:23
Hi BAswaraj:

Hi BAswaraj:
I design the firmare using the PCB ,which is offered by reference design , and software using the same reference , and the Emulator is J-Link.
Thks,
aihuazou

Krutarth
Offline
Last seen: 6 years 11 months ago
Joined: 2015-07-09 19:57
Are you working on windows 7

Are you working on windows 7 or lower? They do not support BLE. Even windows 8 and 10 do not have good support for BLE.

Thanks and Regards,

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi aihuazou,

Hi aihuazou,

What is the operating system on the laptop you are using ?

Thanks MT_dialog

aihuazou
Offline
Last seen: 7 years 2 months ago
Joined: 2015-02-08 03:23
Hi MT_dialog:

Hi MT_dialog:
The operating system is win8.1, I can find the BLE on the computer but can't pair BLE ,and you can tell me how to pair the BLE on the win8.1 or Andriod or linux ?
Thanks aihuazou

MT_dialog
Offline
Last seen: 1 year 9 months ago
Staff
Joined: 2015-06-08 11:34
Hi aihuazou,

Hi aihuazou,

If you are using the reference design of the mouse, you should be able to connect with an android device, can you please try that in order to clear out if its an OS problem ? Also can you please try to enable security, just define the CFG_APP_SEC in order to pair with windows.

Thanks MT_dialog