11 posts / 0 new
Last post
FH_Dialog
Offline
Last seen: 1 month 2 weeks ago
Staff
Joined: 2013-12-06 15:12
RF test script

Do we have RF test script for Anistu 8852?

BB_Dialog
Offline
Last seen: 5 months 6 days ago
Staff
Joined: 2013-12-05 14:44
RF Test Script

Hi Steve,

when the DA14580 is in the Direct_Test_Mode, in theory it can be tested with any BLE tester.
The Anritsu can control our device via the tester's EUT connector, via USB<=>RS232 (using latest Anritsu Firmware, to be selected in the tester).
However, when we were testing the Anritsu MT8852B BLE tester, it appeared that the Anritsu could not handle well the DA14580's deviating Baud-Rate of 111.1 Kbps.
Most of the times it gives an error on control connection.
However, it worked fine with baudrate 38.4 Kbps.
See the table below.
We are in discussion with Anritsu (Europe) whether this can be adapted, so the Anritsu would work on 111.1 KBps too.
For now, we should have the Direct_Test_Mode done at 38.4 Kbps.

DA14580 BLE:
Baud-Rate / Divider-Value / Actual Baud-Rate / Error
115.2Kbps 9 111.1Kbps 3.54%
57.6Kbps 17 58.82Kbps 2.12%
38.4Kbps 26 38.46Kbps 0.16%

Best regards, Dialog Support.

Yamazaki
Offline
Last seen: 3 years 9 months ago
Joined: 2014-01-08 06:00
RF test script

Can it also use Agilent N4010?

BB_Dialog
Offline
Last seen: 5 months 6 days ago
Staff
Joined: 2013-12-05 14:44
RF test script

Hi Yamazaki,

yes, it would probably work if it supports Bluetooth 4.0 (Low Energy).
I'm not sure on this. It's not standard for the N4010, maybe as an option?
Sorry, we have no Agilent N4010 tester.

Best regards, Bart

rofe
Offline
Last seen: 2 years 9 months ago
Joined: 2014-01-28 12:59
Hello,

Hello,

I tried to run some sensitivity measurement but I lack of information how to get number of received packets in the test mode.
I booted both devices in Test Mode. One was set to start TX and 2nd to TX. When I stopped RX then I didn't get any information about
revived packets.

Regards,
Roman

BB_Dialog
Offline
Last seen: 5 months 6 days ago
Staff
Joined: 2013-12-05 14:44
Hi rofe,

Hi rofe,

did you use the ConnectionManager? I assume so.
In CM, when booted in test mode, there's an option in the left hand window named "RX with readback values".
This one should be used for the Rx device.
In the Parameters line, one can read the number of Correctly received packets, number of packets with Sync errors, and number of packets with CRC errors.
e.g. Parameters: 0x01 0x30 0x40 0x8E 0x30 0x00 0x00 0x01 0x00.
The Bytes 0x8E 0x30 0x00 0x00 0x01 0x00 are the ones to read. LSB first!
i.e. 1000 packets were correctly received, one had CRC errors.

Best regards, Dialog Support.

rofe
Offline
Last seen: 2 years 9 months ago
Joined: 2014-01-28 12:59
Yes, I'm using CM and RX with

Yes, I'm using CM and RX with readback but I'm not getting any additional information. I think it is due to using ES3 silicon with latest CM that is made for ES4.
I cannot see attached picture.

BB_Dialog
Offline
Last seen: 5 months 6 days ago
Staff
Joined: 2013-12-05 14:44
Hi,

Hi,

no, sorry, picture is not possible here.
I added some text.
I'll try with ES3.

best regards, Dialog Support.

BB_Dialog
Offline
Last seen: 5 months 6 days ago
Staff
Joined: 2013-12-05 14:44
Hi Rofe,

Hi Rofe,

it should work, but you have to use a motherboard for ES3 (a Rev C board, and not modified for ES4), and use the ES3 hex file.

B.R., Dialog Support

rofe
Offline
Last seen: 2 years 9 months ago
Joined: 2014-01-28 12:59
OK then it should work. I

OK then it should work. I was confused with data representation.

Thank you!

rofe
Offline
Last seen: 2 years 9 months ago
Joined: 2014-01-28 12:59
Hi,

Hi,

I have a problem with setting up packet counter test. When I'm setting up RX side to send 1000 packets it seems to be transmitting packets all the time. In my test first I start RX test then TX with 1000 packets and after a while I'm stopping RX test.

There are my settings.

RX side:
====> [15:24:41.253] Tx <====
opcode : 0x201d
length : 0x01
frequency : 0x00
Payload : 1d 20 01 00

====> [15:24:41.261] Rx <====
event : 0x0E
length : 0x04
parameters: 0x01 0x1D 0x20 0x00
Payload : 0E 04 01 1D 20 00

====> [15:24:51.490] Tx <====
opcode : 0x201f
length : 0x00
Payload : 1f 20 00

====> [15:24:51.500] Rx <====
event : 0x0E
length : 0x06
parameters: 0x01 0x1F 0x20 0x00 0xDF 0x1B
Payload : 0E 06 01 1F 20 00 DF 1B

TX side:
====> [15:24:47.023] Tx <====
opcode : 0x201e
length : 0x05
frequency : 0x00
data length : 0x25
payload type : 0x03
number of packets : 0x03e8
Payload : 1e 20 05 00 25 03 e8 03

====> [15:24:47.026] Rx <====
event : 0x0E
length : 0x04
parameters: 0x01 0x1E 0x20 0x00
Payload : 0E 04 01 1E 20 00

Do you have any suggestions what's wrong? I'm using ES3 test FW.

Regards,
rofe