Serial port not working on basic dev kit

4 posts / 0 new
Last post
gcblair
Offline
Last seen: 6 years 5 months ago
Master
Joined: 2014-09-08 10:21
Serial port not working on basic dev kit

Hi,

I have tried running a few examples such as the perihperal one, blinky with uart and proximity and I cant seem to get the serial port working.
I can see the serial port in device manager and I can open it OK in realterm / terraterm but I never get any characters appearing. I can see the characters entering the uart port in the code

Do I need to disconnect the debugger for it to work? I have tried this to but results are the same

Any help would be appreciated. I am running a windows 8 virtual machine from my native mac, but I dont see how that would affect it if I can see the port in device manager

Thanks

BB_Dialog
Offline
Last seen: 2 years 3 months ago
Staff
Joined: 2013-12-05 14:44
Hi gcblair,

Hi gcblair,

What tool are you using for downloading the software?

Keil?
This must work: I checked this and it works using the blinky-code from the forum website.
Closing the debugger is not needed.

Connection Manager (DL over JLINK)?
This should work (tested by me: blinky).

SmartSnippets's Booter?
If so, what did you select in the SmartSnippets Project selection window at start up?

Please note: the port showing up in the device maanger is the UART port (over JLINK). 

In SmartSnippets: downloading the Blinky code over UART works fine for me.
But I'm having difficulties when downloading over JLINK.
I'll check this with the tool developers and let you know.

Best regards, BB_Dialog.

gcblair
Offline
Last seen: 6 years 5 months ago
Master
Joined: 2014-09-08 10:21
Hi,

Hi,

I am using Keil to download the code and debug it. I can see on an oscilloscope data on the pins
I see one port in device manager that belongs to the Jlink - I can open it as I said but I never receive anything

gcblair
Offline
Last seen: 6 years 5 months ago
Master
Joined: 2014-09-08 10:21
Also when I try to download

Also when I try to download some code to the external flash with smart snippets, it asks me to press the reset button but never detects it and times out